Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

составить программу которая запрашивает 4 даты ч.м.г и выводить сообщения о тех которые приходятся на весну. Вывести на экран дату, с самым поздним годом

5-9 класс

292155960 07 июня 2016 г., 6:53:57 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Irinachayka88
07 июня 2016 г., 8:45:25 (7 лет назад)

const
  n = 4;
  Spring = [3..5];{ Номера весенних месяцев }

var
  ds: array[1..n] of string;
  i, d, m, y, dmax, mmax, ymax, k: integer;
  s, s1: string;

begin
  Writeln('Вводите даты в формате "день месяц год" через пробел');
  k := 0; dmax := 0; mmax := 0; ymax := 0;
  for i := 1 to n do
  begin
    Write(i, ': ');
    Readln(d, m, y);
    if (m in Spring) then
    begin
      k := k + 1;
      Str(d, s);
      Str(m, s1); s := ' ' + s + '.' + s1 + '.';
      Str(y, s1);
      ds[k] := s + s1
    end;
    if ymax < y then begin dmax := d; mmax := m; ymax := y end
    else if ymax = y then
      if mmax < m then begin dmax := d; mmax := m; ymax := y end
      else if dmax < d then begin dmax := d; mmax := m; ymax := y end
  end;
  Writeln;
  if k > 0 then
  begin
    Write('Весенние даты:');
    for i := 1 to k do Write(ds[i]);
    Writeln;
  end;
  Writeln('Самая поздняя дата ', dmax, '.', mmax, '.', ymax)
end.

Тестовое решение:

Вводите даты в формате "день месяц год" через пробел
1: 25 8 2010
2: 3 4 2013
3: 18 5 2011
4: 31 12 2012

Весенние даты: 3.4.2013 18.5.2011
Самая поздняя дата 3.4.2013



Ответить

Другие вопросы из категории

Сколько бит информации содержится в сообщении размером в четверть килобайта?

1.2032
2.2048
3.250
4.2000
5.256
С решением пожалуйста!!!!!

Помогите с задачей!2. Автоматическое устройство осуществило перекодировку двух информационных сообщений равной длины из 8-битной

кодировки ASCII в 16-битную кодировку Unicode в одно новое сообщение, которое при этом увеличилось на 240 байт. Какова длина каждого из исходных сообщений в символах?

(напишите решение)

Читайте также

составьте программу, которая вставляет слово ОБА после каждого слова, заканчивающегося на гласную.

Или

составьте программу, которая определяет на сколько в строке S слов, начинающихся на главную букву больше, чем в строке T

надо решить одну из них

1)Составьте программу,которая заполняет массив e[1..11] случайными целыми числами в диапазоне от -15 до 1 и находит количество элементов кратных 5.

2)Составьте программу,которая заполняет массив e[1..8] случайными целыми числами в диапазоне от 1 до 20 и находит сумму элементов с нечётными значениями и количество элементов кратных 3.
3)Составьте программу,которая заполняет массив e[1..14] случайными целыми числами в диапазоне от -10 до 10,затем изменяет знак положительных элементов на противоположный,а отрицательные элементы заменяет на 0.Спасибо.

1.Составить программу, которая определяет номера позиций символа","

2. Составить программу, которая позволяет заменить все гласные символом "*"

Составить программу, которая выводит на экран в обратном порядке нечетные числа от 29 до 1 в Pascal ABC.

Составить программу,которая выводит на экран сумму нечетных чисел от 1 до 30 в Pascal ABC.


1)Составить программу которая выводит на экран каждое 5-ое число и таких чисел 20.

2)Составить программу которая вычисляет произведение натуральных чисел от 5 до 10.



Вы находитесь на странице вопроса "составить программу которая запрашивает 4 даты ч.м.г и выводить сообщения о тех которые приходятся на весну. Вывести на экран дату, с самым поздним годом", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.