Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Информатика, 9 класс. Паскаль. Задача: даны катеты прямоугольного треугольника. Найдите длину окружности, описанной около треугольника? Заранее

5-9 класс

спасибо.

Moimip1998 25 июня 2013 г., 9:16:53 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
ImWinning1
25 июня 2013 г., 10:35:26 (10 лет назад)

a,b,c - стороны прямоугольного треугольника;
d - радиус описанной окружности около прям. треуг.
e - длинна окружности описанной около прямоуг. треугольника;

var a,b,c,d,e:Real;
begin
writeln ('Введите (через пробел) 2 катета прямоугольного треугольника: ');
readln (a,b); //вводим 2 катета
c:=SQRT((a*a)+(b*b)); //находим 3 сторону (гипотенузу)
d:=0.5*c; //радиус описанной окружности около прям. треуг
e:=2*3.14*d; //теперь находим длину окружности описанной около прям. треуг.
writeln ('Длина окружности описанной около прямоугольного треугольника = ',e);
end.

P.S. то что после // - это комментарий (в паскале он будет выделен другим цветом), это для того что бы было понятно, что сейчас делаем, если комментарии не нужны - их можно удалить, на правильность работы программы это никак не повлияет

+ 0 -
Kola160
25 июня 2013 г., 13:29:41 (10 лет назад)

Program Dlina;
Uses crt;
Var a,b,c,L: real;
Begin clrscr;
Writeln('Введите длины катетов');
Readln(a,b);
c:=sqrt(a*a+b*b);
L:=3.14*c;
Writeln('Длина описанной окружности С=',L);
Readln;
Readkey;
End.

Ответить

Другие вопросы из категории

Известно что кто-то расположил все буквы алфавита по кругу и

заменил каждую букву исходного сообщения на следующую после нее, декорируй сообщения.

Помогите все вроде просто , но я не уверен
На планете Триа использую только числа от 1 до 27. Их записывают с помощью символов «<»,«.» и

«>». Запись числа N выполняется по следующему алгоритму:

1) весь интервал (1..27) делится на 3 равные части: от 1 до 9, от 10 до 18 и от 19 до 27.

2) если число N оказалось в первом интервале, записываем символ «<», если во втором­ символ «.», и если в третьем­ – символ «>»

3) делим оставшийся интервал (в который попало число N) на три части и определяем следующий знак кода, который записывается справа от предыдущих

4) повторяем шаги 2 и 3 до тех пор, пока оставшийся интервал не будет содержать одно число.

Например, число 22 будет закодировано как «>.<» (интервалы 19-27, 22-24, 22).

Определите, какое число записывается как «.<>»?

Читайте также

Помогите, пожалуйста!! Информатика 9 класс. Болел в эти уроки...


(На основе этого документа) Составить программу классификации треугольников по его сторонам (вместо углов входными данными являются стороны треугольника a, b, c.)

найдите пожалуйста ошибку(система паскаль) задача: даны два числа. вывести больше

е из них.

program zadacha6;

var a,b: real;

begin

readln(a,b);

if a>b then writeln ( ' a bolshe ' ) else writeln ( ' a menshee ' );

end.



Вы находитесь на странице вопроса "Информатика, 9 класс. Паскаль. Задача: даны катеты прямоугольного треугольника. Найдите длину окружности, описанной около треугольника? Заранее", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.