Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

определение большого числа из двух не равных чисел введеный с клавеатуры

5-9 класс

Kirill10909070 04 сент. 2014 г., 5:52:41 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Karik95
04 сент. 2014 г., 8:39:57 (9 лет назад)

var a,b,c:real;
begin
writeln('Введи первое число');
readln(a);
writeln('Введи второе число');
readln(b);
if (a<>b) then
if a>b then
writeln('Первое больше второго')
else writeln('Второе больше первого')
else
writeln('Числа равны');
end.

Ответить

Другие вопросы из категории

Автоматическое устройство осуществило перекодировку сообщения, первоначально записанного в 16-битном коде Unicode, в 8-битную кодировку КОИ-8. При этом

информационное сообщение уменьшилось на 160 байт. Какова длина сообщения в символах?

Остались вопросы на которые не могу ответить. 1. можно ли на всех слайдах презентации разместить обьект,не вставляя его на каждом слайде.(если да то

как?) 2.какого эффекта анимации обьекта не существует выход вход переход путь перемещение

Читайте также

Граждане информатики, прошу помощи. Pascal ABC.

Что не так в коде? Надо найти НОК трёх чисел через алгоритм Евклида.
Тест: числа 4,6,18, ответ 36.

Код:

Program No4;
var a,b,c:integer;

{----------АЛГОРИТМ ЕВКЛИДА----------}
function evc (a,b:integer):integer;
var m,m1,m2,z:integer;
begin
z:=0;
//определение большего числа
if a=b then evc:=a else
begin
if a>b then

begin
///m1 - большее число из двух, m2 - меньшее.
m1:=a;
m2:=b;
end

else

begin
m1:=b;
m2:=a;
end;
//определение большего числа - готово
repeat
m:=m1 mod m2; ///Большее число делим на меньшее;
if m=0 then z:=m2 ///Если делится - то НОД есть меньшее число;
else begin ///Иначе меняем большее на меньшее,а меньшее - на остаток от деления (по Евклиду).
m1:=m2;
m2:=m;
end
until z<>0;///Повторяем, пока НОД не появится.

evc:=z;
end;
end;
{---------/АЛГОРИТМ ЕВКЛИДА----------}


{----------АЛГОРИТМ НОК----------}
function znam (a, b, c:integer):integer;
var Nabc,Nab:integer;
begin
Nab:=evc (a,b); ///НОД (а.b) - это результат алгоритма Евклида для чисел А и B:
Nabc:=evc (c, Nab); ///НОД (С,Nab) - это результат алгоритма Евклида для чисел С и Nab:
znam:=a*b*c div Nabc; ///НОК = ПРОИЗВ. ЧИСЕЛ / НОД
end;
{----------АЛГОРИТМ НОК----------}

begin
readln (a,b,c);
writeln (znam (a,b,c));
end.

Заранее спасибо.

1)Определить, является ли числоа делителем числа b. Даны вещественные числа х и у, не равные друг другу. Меньшее из

этих двух чисел заменить половиной их суммы, а большее — их удвоенным произведением.

2)Даны вещественные числа х и у, не равные друг другу. Меньшее из этих двух чисел заменить половиной их суммы, а большее — их удвоенным произведением.

Написать программу для определения максимального числа из данных пяти чисел.

Пользователь вводит пять чисел. Программа выводит ответ: "Максимальное число ... ".
Написать программу в "КуМиРе"

помогите решить пожалуйстаа)

1)Дано целое число ,если оно не четное ,то увеличить его на 3,иначе увеличить его в 5 раз.
2)Даны 2 числа вещественного типа не равные друг другу.Меньшее из них заменить половиной их суммы ,а большее - их удвоенным произведением.
3)Даны 2 числа k и m.Если первое число отрицательно ,то его значение заменить его модулем;иначе второе число заменить единицей .Результат (оба числа) вывести на экран.

Множество А содержит все нечетные числа из диапаазона от 1 до 200

Множесто В - простые числа из этого же диапазона.
Определить дополнение множества В до множества А.

Задачка на Паскале.



Вы находитесь на странице вопроса "определение большого числа из двух не равных чисел введеный с клавеатуры", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.