Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

СРОЧНО.Вот код.Это программа не вся ,здесь даны формулы для вычисления массивов, которые и нужно найти.Написал функцию, вроде бы всё нормально, но не могу

10-11 класс

понять как присвоить вычисляемые значения массиву.Массивы Y(8), Z(10) , W(15) .Если что, то потом необходимо еще подсчитать общее количество в этих массивах.
program pr_10;
const b1 = 4;
b2 = 6;
c1 = 8;
c2 = 3;
d1 = 5;
d2 = 12;
var i,m:integer ; y,z,w:real;
function fY(i:integer):real;
begin
Y:=b1*sin(2*i)+exp((i-5)*ln(b2));
end;
function FZ(i:integer):real;
begin
Z:=c1*(i-4)+c2*sqr(sin(1.5*i));
end;
function FW(i:integer):real;
begin W:=d1*ln(0.1*i)+d2*exp((3)*ln(i-2.5));
end;
begin
for i:=1 to 8 do
begin

Ym[i]:= Y(i);
writeln('Y = ',y);
end;
end.

Slvd 07 мая 2013 г., 8:37:08 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Loraerich
07 мая 2013 г., 10:24:16 (10 лет назад)

program pr_10;
uses crt;
const b1 = 4;
b2 = 6;
c1 = 8;
c2 = 3;
d1 = 5; 
d2 = 12;
 var i: integer; 
Ym: array [1..8] of real; // в разделе переменных не были введены массивы
Zm: array [1..10] of real;
Wm: array [1..15] of real;
function fY(i: integer): real;
var Y: real; // внутренняя переменная функции 
begin Y:=b1*sin(2*i)+exp((i-5)*ln(b2)); 
fY:=Y;
end;
function fZ(i: integer): real; 
var Z: real;
begin Z:=c1*(i-4)+c2*sqr(sin(1.5*i));
 fZ:=Z;
end;
function fW(i: integer): real; 
var W: real;
begin W:=d1*ln(0.1*i)+d2*exp((3)*ln(i-2.5)); 
fW:=W;
end; 
begin 
clrscr;
for i:=1 to 8 do begin Ym[i]:= fY(i); 
writeln('Y = ', Ym[i]:0:5); 
end;
for i:=1 to 10 do begin Zm[i]:= fZ(i); 
writeln('Z = ', Zm[i]:0:5);
end;
for i:=1 to 15 do begin Wm[i]:= fW(i); 
writeln('W = ', Wm[i]:0:5); 
end;
readkey;
end.

+ 0 -
Klioder
07 мая 2013 г., 12:23:55 (10 лет назад)

У тебя функция не возвращает значения?

+ 0 -
EHOTIXA
07 мая 2013 г., 13:10:03 (10 лет назад)

И зачем ты 8 раз присваиваешь m:=8?

+ 0 -
Rudinka
07 мая 2013 г., 14:10:19 (10 лет назад)

это лишее

+ 0 -
Сонечка5Ильина
07 мая 2013 г., 16:23:21 (10 лет назад)

Ну так знаешь в чём дело?

Ответить

Другие вопросы из категории

Почему не используют Odd?

Во всех программах этого сайта на Паскале, когда нужно определить четность числа, используют MOD, хотя для этого есть специальная функция Odd. Эта функция не изучается на начальных этапах изучения Паскаля или есть другие причины?
Отдаю все свои баллы, т.к. меня из-за ника скоро выгонят с сайта, уже получил предупреждение.
Желаю всем успехов!

Дано число n меньше или равно 30 000. Изменяя число i от 1 до n будем записывать получившееся число подряд без пробелов, и получим некое число. Подсчитать

в этом числе количество нулей, единиц, двоек до девяток. Подсчитать общее количество цифр в этом числе

Читайте также

1) Написать программу для вычисления суммы цифр пятизначного числа , введенного с клавиатура

2) Заданы действительные числа a , b , c и d . Написать программу нахождения полусуммы наименьшего и наибольшего из них.
3) Написать программу для вычисления суммы цифр числа , введенного с клавиатуры

Помогите прошу

Написать программу в Delphi 7, содержащую цикл для вычисления функции

y=A_n*X^n+A_(_n_-_1_)*X^(^n^-^1^)+...+A_1*X+A_0
если n=10, A0=0.75, A1=1.6, A2=A3=...=A10=2.0; X изменяется с шагом h=0.2 от X1=0 дo X2=2.0.

Ребята,срочно помогите!)Даю 100 баллов.Составить алгоритм решения задачи на языке C++ . В отчете предоставить три программы с разными операторами

цикла (do ...while, while, for). В алгоритме и программе массивов не использовать.

Я здесь набросал все ,что мог, помогите доработать, написать до конца все эти операторы в одну программу,не получается.

#include <iostream>
#include <cstdlib>
#include <conio.h>
#include <math.h>

using namespace std;
int main()
{
float a,z,xn,xk,dx,R,max,min; float count=0,x;
a = 2.94;xn = 1.5;xk = 5.5;dx = 0.4;
while (xn <= xk)

for (x >= xn; x <= xk; x+=dx, dx = dx + 0.4)
{
do
{
z = a*pow((a*x*x*x*x*x*x*x/cos(a*a*a)+1,31),(1/5));
printf("X = %10f, Z = %10f \n", x, z);
dx = dx + 0.4;
}
while (x <= xk);
return 0;
}
{
max = x;min = z;
if (x > max) max = x;
if (z < max) min = z;
if (count > 2) count = 0;
if (count == 2) printf("X = %10f, Z = %10f \n", x, z);
count=0;
}
cout<<"max="<<max<<"\t min="<<min<<"\n";
cout<<"R="<<min-max<<"\n";
system("PAUSE");
return 0;
}



Вы находитесь на странице вопроса "СРОЧНО.Вот код.Это программа не вся ,здесь даны формулы для вычисления массивов, которые и нужно найти.Написал функцию, вроде бы всё нормально, но не могу", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.