Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Разработать программу, которая находит наибольшее из нескольких целых чисел. Считать, что первое число определяет количество чисел, осталось ввести.

10-11 класс

Grafred4466 11 сент. 2014 г., 5:12:51 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
ИньЯнь
11 сент. 2014 г., 7:43:38 (9 лет назад)

var a, max, i, n:integer;
begin
readln(a);
n:=a-1;
readln(a);
max:=a;
for i:=1 to n do
begin
readln(a);
if a>max then max:=a;
end;
writeln(max);
end.

Ответить

Другие вопросы из категории

Для кодирования некоторой последовательности, состоящей из букв А, Б, В, Г и Д, используется неравномерный двоичный код, позволяющий однозначно

декодировать полученную двоичную последовательность. Вот этот код: А-0, Б-100, В-1010, Г-111, Д-110. Требуется сократить для одной из букв длину кодового слова так, чтобы код по-прежнему можно было декодировать однозначно?Коды остальных букв меняться не должны,каким из указаных способов можно это сделать?
1)Для букв В-101
2)В-010
3)неизвестно
4)Б-10

Дана матрица 5Х5.

вывести ее в транспортированом виде, поменять местами строки со столбцами.
P.S Turbo Pascal

Читайте также

Сделайте пожалуйста блок-схему или код в small basic. Дан массив из 20 целых чисел. В массиве хранятся результаты соревнований по спортивной стрельбе.

Один элемент массива соответствует количеству очков, набранных одним участником соревнований, и имеет значение от 0 до 30 включительно. Необходимо разработать программу, которая по данным массива вычисляет максимальное количество очков среди участников соревнований, и количество участников набравшее зачётное количество очков. Зачётное количество очков 18. Гарантируется, что хотя бы один участник соревнований набрал зачётное количество очков.

Составить программу на языке Паскаль: 1)Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2)В массиве М из 10 целых

чисел найти количество элементов равных 3. 3)В массиве из 8 целых найти номер массива с наибольшим значением. 4)В массиве из 12 целых чисел найти количество и сумму элементов, расположенных до максимального элемента. 5)Для массива из 15 вещественных подсчитать количество элементов массива меньших суммы первого и последнего элементов массива.

Напишите прог-у на паскале... ПЛИИИИИИИИИИЗ 1)даны действительные числа a1, b1, c1, a2, b2, c2. Составьте программу, которая находит координаты точки

пересечения прямых, описываемых уравнениями a1x+b1x=c1 и a2x+b2x=c2. Если прямые пересекаются или не существуют-выдать соответствующее сообщение. 2) даны действительные числа a1, b1, a2, b2. Составьте программу, которая определяет, какая из точек A(a1;b1) или B(a2;b2) лежит на прямой у=2х+1. Если такой точки нет-вывести соответсвующее сообщение.

Составить на языке Паскаль программу, которая запрашивает с клавиатуры N целых чисел и считает, сколько из них положительных, сколько отрицательных и сколь

ко нулей. Разработать для программы не менее двух тестов и доказать правильность её работы.



Вы находитесь на странице вопроса "Разработать программу, которая находит наибольшее из нескольких целых чисел. Считать, что первое число определяет количество чисел, осталось ввести.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.