Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

ввести с клавиатуры пару чисел,меньшее из них заменить их произведением.большее суммой этих чисел.При воде равных чисел-выход из программы

5-9 класс

MarinkOn 16 мая 2013 г., 15:46:39 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Lisaizlesa1
16 мая 2013 г., 16:20:06 (10 лет назад)

program z;

var a,b,a:real;   {при желании можна real поменять на integer }

begin

writeln ('Vvedit a i b');

readln (a,b);

if a<b then begin

 c:=a;             {3-я переменная нужна чтобы не потерять неременную a} 

 a:=a*b;

 b:=b+c;

 writeln (a,b);      {вывод даных}

readln                 {задержка экрана}

end;

if a>b then begin   {NEвкоем случае не менять эту строчку на "else"}

 c:=b;

 b:=a*b;

 a:=a+c; 

writeln (a,b);

readln  

end   {ПЕРЕД "end" точка з запятой Не обязательная}

end. 

Ответить

Другие вопросы из категории

Пожалуста как можно скорей

Составте пожалуйста решение в паскале к задаче: Окр вписана в квадрат. Sквадрата =36.Найти радиус и площадь круга.

Заполните массив с клавиатуры целыми числами и найдите сумму элементов массива с i1-го по i2-й (i1 и i2 вводить с клавиатуры).

Входные данные:
в первой строке целое число n (0 < n ≤ 100) - кол-во элементов в массиве и целые числа i1 и i2 (0 < i1, i2 ≤ 100). Во второй строке целые числа Х1, Х2,..,Хn разделенные пробелом (числа по модулю не превосходят 32000) - значения элементов массива.

Выходные данные:
сумма элементов массива c номерами от i1 до i2.

(Написать программу на Паскале)

Выполните операцию сложения над двоичными числами:

а) 101010+1101;
б) 1010+1010;
в) 10101+111.

найдите произведение 1*2*3*...*15

Читайте также

1)составьте программу ,которая предлагает ввести с клавиатуры две строки ,а затем выводит это строки на экран в алфавитном порядке

например армия(строка а)
арбуз (строка б)
2)составьте программу ,которая предлагает ввести с клавиатуры две строки а и б ,соеденяет их и выводит результат в одну строку
например: тепло(строка а)
ход(строка б)

Задачи по Паскалю.Условный оператор.

1.Даны два действительных числа меньшее из них замените полусуммой их, а большее их произведением.
2.Найдите решение уравнения ах+ в=0, если оно существует,если а=0
3.написать программу удвоения меньшего из двух чисел



Вы находитесь на странице вопроса "ввести с клавиатуры пару чисел,меньшее из них заменить их произведением.большее суммой этих чисел.При воде равных чисел-выход из программы", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.