Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Помогите пожалуйста составить задачу:Даны 2 числа,меньшее из них заменить их полусуммой этих чисел,а большее произведением. Задача решение в паскале.

5-9 класс

Irishka17072001 12 авг. 2014 г., 15:24:13 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
SheludkoMasha
12 авг. 2014 г., 18:06:33 (9 лет назад)

var x,y,c:ineger;
begin
readln(x,y);
c:=y;
if x>y then
begin
y:=(x+y)/2;
x:=x*c;
end;

if xbegin
c:=x;
x:=(x+y)/2;
y:=x*c;
end;
end.

Ответить

Другие вопросы из категории

Дана

таблица в режиме отображения формул. Записать эту же таблицу в режиме
отображения значений

Помогите отредактировать программу - Паскаль. Где-то ошибка.

Необходимо удалить первый кратный 3 элемент массива.
program udalenie;
var i,n,k:integer;
a:array[1..1000] of integer;
begin
assign (input,'input.txt');
assign (output,'output.txt');
reset (input);
rewrite (output);
readln(n);
for i:=1 to n do read (a[i]);
while i<=n do
if a[i] mod 3=0 then
begin
for i:=k to n-1 do
a[i]:=a[i+1];
n:=n-1; exit;
end;
for i:=1 to n do write(a[i],' ');
close (input);
close (output);
end.

Читайте также

Задачи по Паскалю.Условный оператор.

1.Даны два действительных числа меньшее из них замените полусуммой их, а большее их произведением.
2.Найдите решение уравнения ах+ в=0, если оно существует,если а=0
3.написать программу удвоения меньшего из двух чисел

1.Если данное натурального число меньше 10, то прибавьте 10, иначе вычьте. Решить через Паскаль var, begin-end. 2. Дано трехзначное число.

Верно ли, что его первая цифра меньше последней? Решить также. Помогите пожалуйста!



Вы находитесь на странице вопроса "Помогите пожалуйста составить задачу:Даны 2 числа,меньшее из них заменить их полусуммой этих чисел,а большее произведением. Задача решение в паскале.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.