Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

1.Если данное натурального число меньше 10, то прибавьте 10, иначе вычьте. Решить через Паскаль var, begin-end. 2. Дано трехзначное число.

5-9 класс

Верно ли, что его первая цифра меньше последней? Решить также. Помогите пожалуйста!

Ezhechka 27 окт. 2013 г., 18:26:06 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Bdhgsgdgd
27 окт. 2013 г., 19:38:26 (10 лет назад)

 var
  x : integer;
begin
  read (x);
  if x < 10 then x := x + 10 else x := x - 1;
  write (x);
end.

var
  x : integer;
begin
  read (x);
  if x mod 10 > x div 100 then write ('Yes') else write ('No');
end.

Ответить

Другие вопросы из категории

7.Дано

А=10010012,
В=10011002.
Какое из чисел С, записанных в десятичной
форме, отвечает условию А<С<В?

Активная ячейка - это ячейка:

Вариант 1
для записи команд.

Вариант 2
содержащая формулу, включающую в себя имя ячейки, в которой выполняется
ввод данных.

Вариант 3
в которой содержится ссылка на содержимое зависимой ячейки.

Вариант 4
в которой выполняется ввод данных.

P.S решить задачи 1. мальчик может бегать в три раза быстрее,чем ходить .Скорость его ходьбы составляет 4км/ч. Он принял участие в марафонском

забеге, но сошел с дистанции, пробежав X км. Сколько времени он затратил но преодоление этой дистанции?

2.Даны две точки на плоскости (х1 ; у1) и (х2; у2). Необходимо определить какая из точек находится дальше (ближе) от начала коорддинатных осей.

3. Написать программу, распознающую по длинам сторон среди всех треугольников прямоугильные.

4. Определить в вещественном числе количество цифр до запятой.

5. В линейной таблице из 16 элементов все числа хранятся в порядке возврастания. Необходимо все числа в таблице расположить в порядке убывания

Читайте также

дано натуральное число N, Написать ему выводящую на экран последовательность натуральность натуральных чисел от 1 до N, задание 2 дано натуральное число

N, Написать ему выводящую на экран последовательность натуральность натуральных чисел отN до 1, номер 3 Даны натуральные числа N и К.Написать программу выводящую на экран последовательность из N чисел , каждое из которых равно К хотя бы что нибудь решите помогите очень надо!!!!!!!!!

ОЧЕНЬ НУЖНО !!!!!!!!!!!!!!!!!!!Дано натуральное число , если оно двузначное и делится на сумму своих цифр, то его разделить на эту сумму, если оно

трехзначное и делится либо на 7, либо на 11, то его разделить на цело на 11. В остальных случаях разделить число на 10. ( сделать с помощью программы Pascal) Заранее огромное спасибо))))

Дано натуральное число. Если в нём есть цифры a и b, то определить какая из них расположена в числе правее. Если одна или обе эти цифры встречаются в

числе несколько раз, то должны быть учтены самые правые из одинаковых цифр.
(паскаль)

Вариант № 2 1)Подсчитать сумму квадратов всех отрицательных и четных чисел из 10 вводимых. 2) Даны натуральные числа от 35 до 87.

Найти и напечатать те из них, которые при делении на 7 дают остаток 1, 2 или 5.

3)Дано целое число а и натуральное (целое неотрицательное) число n. Вычислить а в степени n, используя в программе лишь операцию умножения.

4)Введите последовательность из n целых чисел. Найти наибольшее из всех отрицательных чисел. Вывести его значение и порядковый номер.

5)Вычислите: 99-97+95-93+91-89+....+7-5+3-1.

6)Доказать (путем перебора возможных значений), что для любых величин А, В, С типа Boolean следующая пара логических выражений имеет одинаковые значения (эквивалентны): A OR (B AND C) и (A OR B) AND (A OR C).

1)найти количесво делителей натурального числа,сколько из них чётных? 2) дано натуральное число: найти две первые цыфры числа

верно ли,что первая цыфраа данного числа чётная?

3)найти все трёхзначные числа,которые состоят из разных цыфр,а их сумма равна А(А вводится с клавиатуры)

4)найти все симметричные натуральные числа(палиндромаиз промежутка от А до В(А и В вводится с клавиатуры)



Вы находитесь на странице вопроса "1.Если данное натурального число меньше 10, то прибавьте 10, иначе вычьте. Решить через Паскаль var, begin-end. 2. Дано трехзначное число.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.