Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

ОЧЕНЬ НУЖНО !!!!!!!!!!!!!!!!!!!Дано натуральное число , если оно двузначное и делится на сумму своих цифр, то его разделить на эту сумму, если оно

5-9 класс

трехзначное и делится либо на 7, либо на 11, то его разделить на цело на 11. В остальных случаях разделить число на 10. ( сделать с помощью программы Pascal) Заранее огромное спасибо))))

Tomashewitchse 25 дек. 2013 г., 6:41:48 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Александрушка152
25 дек. 2013 г., 9:12:56 (10 лет назад)

var
a, x, y, k, r: integer;
begin
k := 0;
readln(a);
r := a;
x := a div 10;
y := a mod 10;
while r > 0 do
begin
r := r div 10;
k := k + 1;
end;
if (k = 2) and (a mod (x + y) = 0) then begin
writeln(a/(x + y));
halt;
end;
if (k = 3) and ((a mod 7 = 0) or (a mod 11 = 0)) then begin
writeln(a div 11);
halt;
end;
writeln(a / 10);
end.

Ответить

Другие вопросы из категории

Дано словесное описание алгоритма: z:=2; d:=7; k=0; Начало цикла пока d>=z

d:=d – z; k=k+1;

конец цикла;

Вывести результат на экран.

Составить блок-схему в виде циклического алгоритма. Определить количество циклов k. Написать программу на языке Паскаль с использованием оператора цикла с предусловием.

Читайте также

дано натуральное число N, Написать ему выводящую на экран последовательность натуральность натуральных чисел от 1 до N, задание 2 дано натуральное число

N, Написать ему выводящую на экран последовательность натуральность натуральных чисел отN до 1, номер 3 Даны натуральные числа N и К.Написать программу выводящую на экран последовательность из N чисел , каждое из которых равно К хотя бы что нибудь решите помогите очень надо!!!!!!!!!

Нужна помощь в составлении алгоритма (паскаль АВС) -8 класс.

1 задание: Составьте программу вычисления количества двухзначных чисел,которые кратны 2 и 3.
2 задание: Составьте программу,выводящую на экран все двузначные числа,у которых первая цифра в два раза больше второй.
3 задание: Найдите количество двузначных чисел,которые делятся на сумму своих цифр.
P.S. Помогите пожалуйста! Очень нужно и срочно! Если можете,то нужно всё сделать; если же нет,то хотя-бы одну или две задачи. Заранее спасибо!!!)))

Ребят задача на языке Pascal...

Дано целое число, если оно двузначное, то умножить на 2, в противном случае вычесть 10.

1.Составьте программу, выводящую на экран все двухзначные числа, у которых сумма цифр равна 8.

2.Составьте программу вычисления количества трёхзначных чисел палиндромов ( чисел, которые читаются одинаково слева направо и справа налево).
3.Найти двухзначные числа, которые делятся на сумму своих цифр
4.Составьте программу вывода количества трёхзначных чисел, у которых цифры упорядочены строго по убыванию.
РЕБЯТА СРОЧНО!!!!!!!!!!!



Вы находитесь на странице вопроса "ОЧЕНЬ НУЖНО !!!!!!!!!!!!!!!!!!!Дано натуральное число , если оно двузначное и делится на сумму своих цифр, то его разделить на эту сумму, если оно", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.