Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Даны три числа x,y,z.Если их значения упорядочены по убыванию, то удвоить их; в противном случае заменить значение каждой переменной на противоположное.

5-9 класс

Помогите пожалуйста составить программу Paskal.)))))))))))))

Art1k228 06 сент. 2013 г., 6:30:43 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Rusprolan1
06 сент. 2013 г., 8:43:10 (10 лет назад)

Program Zamena;
Uses Crt;
var x,y,z:real;
       b:boolean;
begin
     clrscr;
     write('Введите x:');
     readln(x);
     write('Введите y:');
     readln(y);
     write('Введите z:');
     readln(z);
     b:=((x>y) and (y>z) and (z<y) and (x>z));
if (b=true) then
    begin
       x:=2*x;
        y:=2*y;
        z:=2*z;
    end

else
      begin
          x:=-x;
          y:=-y;
          z:=-z;
      end;
writeln('x =',x);
writeln('y =',y);
writeln('z =',z);
readkey;
end.

Ответить

Другие вопросы из категории

Звания: майор, капитан, летинант, старшина, сержант и рефрельтор

Специальности: летчик, артелерист, танкист, минометчик, сапер, свизист.
1тур: летинант выйграл у летчика
майор у танкиста, сержант у минометчика
2тур: капитан у танкиста
3тур и 4: минметчик не участвовал поэтому свободными от игры окозались капитан и рефрельтор
4 тур: майор выйграл у свизиста
5 тур: победители литенант и майор. хуже всех сиграл майор!

Артур всегда очень боялся знакомиться с девушками. Дело даже не в природной стеснительности Артура, и даже не столько в том, что Артур не знает, о чем

говорить с девушками. Просто Артур с детства не выговаривает букву «р» и очень этого стесняется. Поэтому Артур старается не произносить лишний раз слова, в которых есть эта ненавистная ему буква.Однажды друзья познакомили Артура с девушкой по имени Нина (о, какое прекрасное имя!). Она была очаровательна и очень болтлива, поэтому Артуру почти не нужно было подбирать слова — она заполняла неловкую тишину за него. Разумеется, он пригласил ее в кафе выпить чашечку кофе. Артур даже продумал все свои реплики заранее: «Счастлив тебя видеть», «Ты сегодня восхитительна», «Да, конечно, я внимательно тебя слушаю», «И что дальше?», «Счет, пожалуйста» и, конечно, «Я позвоню тебе на днях, не скучай».Но, как известно, не бывает идеальных планов. Все шло как по маслу, но вдруг, сидя за столиком в кафе, Нина сказала, что ужасно не выспалась и не отказалась бы от N чашек кофе. И тут Артур понял, что он не обдумал заранее, как он будет делать заказ. Понятно, что нужно сказать что-то вроде: «Сколько-то чашек кофе, пожалуйста», но вот сколько же чашек нужно, чтобы Нина так и не поняла, что Артур не выговаривает букву «р»? Явно нужно заказать не меньше, чем N + 1

Дан алгоритм на языке ГРИС:

шаг шаг поворот поворот поворот шаг шаг прыжок прыжок прыжок шаг шаг поворот поворот поворот шаг шаг прыжок прыжок прыжок шаг шаг поворот по-ворот поворот шаг шаг прыжок прыжок прыжок шаг шаг поворот поворот поворот шаг шаг прыжок прыжок прыжок.

Читайте также

1.Дано целое число,лежащее в диапазоне 1-999.Вывести его строку-описание вида "четное двузначное число","нечетное трехзначное число" и т.д.

2.Даны 3 переменные вещественного типа:А,В,С.Если их значения упорядочены по возрастанию,то удвоить их.В противном случае заменить значение каждой переменной на противоположное.Вывести новые значения переменных А,В,С.
3. Даны 3 целых числа,одно из которых отлично от двух других,равных между собой. Определить порядковый номер числа,отличного от остальных.

даны два числа. Если первое число нечетное, то найти сумму кубов, а иначе - куб суммы. даны три числа. Если хотя бы одно из чи

сел - отрицательное, то найти Iа+ b+cI иначе а+b+c +d в корне.

Даны три числа. Если произведение данных чисел - отрицательное, то каждое число возвести в квадрат, иначе найти модуль каждого числа

ПОМОГИТЕ ОЧЕНЬ ПРОШУ

Pascal.

Даны три переменные вещественного типа: A, B, C. Если их значения упо- рядочены по возрастанию или убыванию, то удвоить их; в противном слу- чае заменить значение каждой переменной на противоположное. Вывести новые значения переменных A, B, C.

Работа в паскале.

Даны три переменные: x, y, z. Если их значения делятся без остатка на 4, то удвоить их; в противном случае заменить значение переменной на противоположное.



Вы находитесь на странице вопроса "Даны три числа x,y,z.Если их значения упорядочены по убыванию, то удвоить их; в противном случае заменить значение каждой переменной на противоположное.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.