Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

даны два числа. Если первое число нечетное, то найти сумму кубов, а иначе - куб суммы. даны три числа. Если хотя бы одно из чи

5-9 класс

сел - отрицательное, то найти Iа+ b+cI иначе а+b+c +d в корне.

Даны три числа. Если произведение данных чисел - отрицательное, то каждое число возвести в квадрат, иначе найти модуль каждого числа

ПОМОГИТЕ ОЧЕНЬ ПРОШУ

баскетболисткаа 09 нояб. 2013 г., 7:19:03 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Gamebot
09 нояб. 2013 г., 8:47:43 (10 лет назад)

Уже писал, но попал в баг(

Так вот. В паскале это будет так:

1)var a,b,c:integer;

begin

         readln(a,b);

         if a div 2 =0 then c:=(a+b)*(a+b)*(a+b);

                              else c:=a*a*a+b*b*b;

         writeln(c);

end.

2)var a,b,c:integer;

          d:real;

begin

          readln(a,b,c);

          if (a<0) or (b<0) or (c<0) then d:=abs(a+b+c)

                                                       else d:=sqrt(a+b+c);

         writeln(d:0:2);

end.

3)var a,b,c:integer;

begin

          readln(a,b,c);

          if (a*b*c<0) then begin a:=a*a; b:=b*b; c:=c*c; end

                               else begin a:=abs(a); b:=abs(b); c:=abs(c); end;

          writeln( a, ' ', b, ' ', c);

end.

Вот так вот.

Ответить

Читайте также

Напишите программу, которая сравнивает два числа: 2 в степени 100 и 3 в степени 50. Программа должна выводить слово "больше", если первое число больше

второго, "равно" — если числа равны, "меньше" — если первое число меньше второго. Сами числа выводить не нужно.

Даны числа a,b,c. Составить программу, выводящую на экран сообщение, в зависимости от того какой треугольник можно построить с такими длина сторон:

равносторонний,равнобедренный или какой либо другой.

Вот ещё одна

Составить программу:Даны а,b,c-целые числа.Если они большн 0-вычислите сумму их квадратов;а если хотя бы одно из них четно-вычислите их сумму и произведение.

Пожалуйста ребят.



Вы находитесь на странице вопроса "даны два числа. Если первое число нечетное, то найти сумму кубов, а иначе - куб суммы. даны три числа. Если хотя бы одно из чи", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.