Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

помогите решить 8 и 9 задачу!Спасибо!

10-11 класс

Lexakravchenko 01 марта 2014 г., 15:19:26 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Burridge
01 марта 2014 г., 16:21:26 (10 лет назад)

program tet;
var s:integer;
i,j:byte;
a:array[1..10,1..12] of integer;
begin{заполняем массив случайными трёхзначными числами.}
for i:=1 to 10  dofor j:=1 to 12 doa[i,j]:=100*random(9)+10*random(9)+random(9);{Выводим массив}
for i:=1 to 10  do begin writeln;for j:=1 to 12 do write(a[i,j]:5); end;
{Начинаем со второй строки}
i:=2;
while i<=10 do begin
for j:=1 to 12 do{проверяем на чётность и складываем}if a[i,j] mod 2=0 then s:=s+a[i,j]; i:=i+2;end;
writeln('s=',s);
end.

Ответить

Другие вопросы из категории

Всем привет, помогите написать программу в паскале, смысл прост. Программа должна переводить число из шестнадцатиричной системы счисления в дестяричную и

наоборот, тоесть после вводе числа- FFF программа должна вывести число 4095 и ниже снова FFF, программа должна быть простая и не слишком умная. Заранее спасибо

Помогите, пожалуйста. Нужно срочно..

Три свидетеля падения метеорита сообщили сведения траектории падения. Один утверждал, что наблюдал падение красного метеорита в лесной массив, Второй - чёрный метеорит упал в озеро, а Третий – метеорит был точно не красный, и по все вероятности, что упал в болото. Когда удалось отыскать метеорит, выяснилось, что каждый из свидетелей определил правильно лишь один из параметров падения, а в другом ошибся. Куда упал метеорит и какого был цвет?

1)
Метеорит красного цвета


2)
Лес


3)
Метеорит черного цвета


4)
Озеро


5)
Болото

Читайте также

Помогите решить задачу.

Дан массив А1,.......Аn. найти максимальный и минимальный элементы и поменять их местами. Вот задача которую я делал:

program zadacha;
const
k=50;
var
a:array[1..k] of integer;
n,i:1..k;
c,v,max,min,prom:integer;
begin
for i:=1 to n do begin (здесь выскакивает ошибка о проверки диапазона)
a[i]:=random(50);
write(a[i],' ');
end;
max:=a[1];
min:=a[1];
for i:=1 to n do begin
if a[i]>max then begin
max:=a[i];
c:=i;
end;
if a[i]<min the begin
min:=a[i];
v:=i;
end;
end;
writeln('max=',max,'min=',min);
prom:=max; (вот с этой строчки и до конца помогите решить)
max:=min;
min:=prom;
writeln;
writeln('Полученный массив');
for i:=1 to n do
write(a[i], ' ');
readln;
end.

Помогите решить задачку очень-очень надо:)) спасибо:* Устав от повседневных дел, Иван Петрович устроил себе отпуск - пошел на охоту. На

расстоянии N метров, его охотничья собака Гайзарда заметила зайца. Через какое время она догонит его если скорость зайца V1 м / с, а скорость собаки V2 м / с? Следует отметить, что Гайзарда бегает быстрее любого зайца.
Входные данные:
Программа на вход получает три целых числа N, V1, V2 (0 ≤ N ≤ 103, 0 <V1, V2 <20).
Выходные данные:
Программа должна вывести время за собака догонит зайца с точностью до сотых.

Решить любую из двух задач. Если две - то спасибо :)

1) В одномерном массиве встречаются нули. Согнать их всех в одну сторону.(задача на пузырьковый метод)
2) После ввода одномерного массива:
-сначало идут положительные по возрастанию

-потом все нули

-потом все отрицательные чила по возрастанию

Пример:-1 5 -7 0 3 0 -2 6 8

вывод: 3 5 6 8 0 0 -7 -2 -1

Помогите, очень прошу вас.

Помогите решить две задачки (Паскаль)

Задание 1
В одномерном массиве случайных вещественных числе F(17) определить количество положительных элементов и их сумму.

Задание 2
В матрице L(5,5) случайных вещественных чисел определить максимальный элемент выше побочной диагонали, поменять его местами с элементом 2 строки 2 столбца.

Большая просьба расписать задачу подробно , хочу не просто списать решения , а понять его и научиться решать сам , огромное спасибо.



Вы находитесь на странице вопроса "помогите решить 8 и 9 задачу!Спасибо!", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.