Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Составить блок-схему алгоритма определения суммы положительных чисел из десяти.

10-11 класс

Lizidekond 24 дек. 2015 г., 14:51:37 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
кристинка04
24 дек. 2015 г., 16:13:43 (8 лет назад)

Program pr;

uses crt;

Var i,a,x:integer;

Begin

x:=0;

for i:=1 to 10 do

Begin

readln(a);

if a>0 then x:=x+1;

end;

Writeln('Кол-во положительных чисел= ', x);

readln;

end.

Ответить

Другие вопросы из категории

1.Напиши

программу , которая присваивает переменной х значение 9, а затем выводит на
экран: в первой строке это значение с поясняющей надписью (например значение
х равно 9), а во второй – квадрат этого значения (тоже – с поясняющей
надписью).

Помогите написать программу в паскале. За ранее спасибо. Задача на двумерный массив. Задание 1.

Заполнить двухмерный массив ABCD [1..5,1..5] константами:


1 4 7 -10 13
7 10 13 15 19
13 -16 19 22 25
19 22 25 -28 31
25 28 31 34 37

а) Удвоить все элементы массива, которые > 3.
б) Найти сумму всех элементов полученного массива.
в) Вывести на экран исходный и полученный массив.

Задача 1. Информационные объем одного символа некоторого сообщения равен 6 битам. Сколько символов входит в алфавит, с помощью которого было составлено

это сообщение?
Задача 2. Информационное сообщение имеет объем 3 Кбайта. Сколько в нем символов, если размер алфавита, с помощью которого оно было составлено, равен 16?

Составить программу на языке паскаль При поступлении в вуз абитуриенты , получившие "двойку" на первом экзамене , ко второму не

допускаются . В массиве A[n] записаны оценки экзаменующихся , полученные на первом экзамене . Подсчитать , сколько человек не допущено ко второму экзамену .

Читайте также

Нужно составить блок-схему алгоритма подготовки к сдаче к экзамену.

Я не могу сочинить этот "алгоритм", помогите ;)
Блок-схемы строить не надо, просто описать, что надо делать.

Задание № 1) Разработать блок схему алгоритма, который проверяет, является ли четным введенное с клавиатуры число

Задание 2) Разработать блок схему алгоритма? для вычисления и вывода на экран суммы 5 случайных числе в диапазоне 0..36.

Составить блок схему алгоритма

Задание: даны действительные а1,...,аn. Вычислить сумму положительных и произведение четных членов данного массива, если таких членов нет, выдать сообщение

Задание. Составьте блок схему алгоритма решения задачи и программу на языке Turbo Pascal c использованием условного оператора.

Даны три целых числа.Найти кол-во положительных чисел в исходном наборе.



Вы находитесь на странице вопроса "Составить блок-схему алгоритма определения суммы положительных чисел из десяти.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.