Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

дана строка,заканчивающаяся точкой.Подсчитать, сколько слов в строке. (язык С++)

10-11 класс

Julianya 17 марта 2017 г., 14:02:06 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ivanova61
17 марта 2017 г., 15:39:23 (7 лет назад)

#include <iostream>

#include <string>

using namespace std;

 

int main()

{

int words_value=0;

string s;

bool check = true ;

getline(cin,s,'.');

int size = s.size();

if(s.at()!=' ' )

words_value = 1;

else 

return 0 ;

for(int i =0;i<size;i++)

{

if(!check) 

{

if(s.at(i) != ' ')

++words;

check = true;

}

if(s.at(i)== ' ') {

check = false ;

i++ ;}

}

cout << words; 

}

Ответить

Другие вопросы из категории

Три свидетеля дали показания, что преступники скрылись с места преступления а) на белой Волге; б) на красных Жигулях;

в) не на белом Москвиче. Каждый из них в чем-то ошибался. На какой машине скрылись преступники?

Документ (без упаковки) можно передать по каналу связи с одного компьютера на другой за 1 минуту 30 секунд. Если предварительно упаковать документ

архиватором, передать упакованный документ, а потом распаковать на компьютере получателя, то общее время передачи (включая упаковку и распаковку) составит 40 секунд. При этом на упаковку и распаковку всего ушло 13 секунд. Размер исходного документа 50 мбайт. Чему равен размер упакованного документа (в Мбайт)?.

Читайте также

Напишите программу (Паскаль):

выводится 5 строк, в которых сначала записан порядковый номер строки с точкой, а затем слово. вывести слова в алфавитном порядке.
например :
1.информатика
2.химия
3.математика
4.физкультура
5.литература
Вывод: 1.информатика
5.литература
3.математика
4.физкультура
2.химия

Составить программы: 1.Дана строка символов, среди которых есть двоеточие. Определить, сколько символов следуют за двоеточием.

2.Дана строка символов, среди которых есть одна открывающаяся и одна закрывающаяся скобка. Подсчитать, сколько слов расположено внутри этих скобок.

3.Дана строка. Удалить из нее все запятые и подсчитать, сколько получилось удаленных символов.

Помогите, пожалуйста!

Помогите пожалуйста составить

программу на ''Pascal ABC'')

Дана строка, содержащая текст на русском языке, и некоторая буква. Подсчитать, сколько слов начинается с указанной буквы.



Вы находитесь на странице вопроса "дана строка,заканчивающаяся точкой.Подсчитать, сколько слов в строке. (язык С++)", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.