Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Помогите с паскалем.В линейный массив вещественных чисел на 8-е место вставить элемент, равный сумме первых 10 элементов массива.

10-11 класс

Elmira08 25 марта 2017 г., 15:53:45 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Милашшшшка2002
25 марта 2017 г., 18:40:33 (7 лет назад)

Var n, i: Integer;
    sum: Double;
    a: Array[1..1000] of Double;
begin
    ReadLn(n);
    for i:=1 to n do Read(a[i]);
    sum:=0;
    for i:=1 to 10 do sum:=sum+a[i];
    a[8]:=sum;
    WriteLn('--');
    for i:=1 to n do Write(a[i]:0:3, ', ');
end.

Ответить

Читайте также

на языке паскаль 1)дан массив натуральных чисел найдите сумму всех его элементов 2)вычислить количество положительных чисел

среди 10 элементов вещественного массива

3)заполнить массив из n целых чисел.выяснить какое число встречается раньше-положительное или отрицательное.

4)в целочисленном массиве есть отрицательные элементы.вывести номера этих элементов

Составить программу Дан массив натуральных чисел , размерность -12 !) Заполнение массива производить с клавиатуры 2) Вывести на печать

только элементы кратные 2

3)Найти сумму первых пяти элементов

Составить программу Дан массив целых чисел , размерность -12

1) Заполнение массива производить случайными числами из диапозона [-10;35]

2)Вывести на печать только положительные элементы

3)Найти количество отрицательных элементов

Составить программу

Известны данные о выпуске прождукции ( ткани в метрах ) ткацким цехом текстильного комбината за каждый день месяца . Определить количество ткани ( метров) произведенных цехом за месяц .

Составить программу на языке Паскаль: 1)Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2)В массиве М из 10 целых

чисел найти количество элементов равных 3. 3)В массиве из 8 целых найти номер массива с наибольшим значением. 4)В массиве из 12 целых чисел найти количество и сумму элементов, расположенных до максимального элемента. 5)Для массива из 15 вещественных подсчитать количество элементов массива меньших суммы первого и последнего элементов массива.



Вы находитесь на странице вопроса "Помогите с паскалем.В линейный массив вещественных чисел на 8-е место вставить элемент, равный сумме первых 10 элементов массива.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.