Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Вывести все элементы массива кратные 3, помогите пожалуйста с кодом

10-11 класс

Bravobums 30 дек. 2016 г., 4:55:20 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Istominalysi
30 дек. 2016 г., 5:26:36 (7 лет назад)

Код на паскале?
var i:integer; a:array[1..15] of integer;
begin
randomize;
for i:=1 to 15 do begin
a[i]:=random(20)+1;
if a[i] mod 3=0 then writeln(a[i]);
end;
readln;
end.

+ 0 -
Taniana2
30 дек. 2016 г., 7:31:47 (7 лет назад)

Паскаль АВС

Program  GreatWhite;
const
  n=50;
var
  mass: array [1..n] of integer;
  i: integer;
begin
  writeln('*** Alphaeus is thinking... ***');
  writeln('***          OK             ***');
  writeln('Среди элементов массива программа находит числа, кратные 3');
  writeln('*** Вычисляю... ***');
  randomize;
  for i:=1 to n do begin
    mass[i]:=random(100)-50;
    if mass[i] mod 3=0 then writeln(mass[i]);
  end;
end.

Ответить

Другие вопросы из категории

Заполнить массив случайными числами и отсортировать его. Ввести число Х. Используя двоичный поиск, определить, есть ли в массиве число, равное Х.

Подсчитать количество сравнений.
Пример:
Массив:
147392452
После сортировки:
122344579
Введите число Х:
2
Число 2 найдено.
Количество сравнений: 2

язык С !!! срочно КУЧУ БАЛЛОВ ДАЮ!!!

Составить программу, которая по формулам для арифметической
прогрессии находит сумму n первых элементов прогрессии и значения
трех элементов с номерами (n–1), n и (n+1). Число n, первый элемент и
разность прогрессии вводятся пользователем. Вывести значения
элементов в форме таблицы, где первая строка – номер, а вторая –
значение.

даны две строки произвольного текста. составить процедуру, результатом работы которой является символ, заданный при обращении к процедуре, если этот

символ не является буквой, и соответствующая строчная (малая) буква в противном случае. в программе обрабатываются две строки.

Читайте также

Дан целочисленный массив из 30 элементов. Элементы массива могут принимать целые значения от 0 до 1000. Опишите на русском языке или на одном из языков

программирования алгоритм, позволяющий найти и вывести сумму элементов массива, кратных тринадцати. Гарантируется, что в исходном массиве есть хотя бы один элемент, значение которого делится на тринадцать. Исходные данные объявлены так, как показано ниже. Запрещается использовать переменные, не описанные ниже, но разрешается не использовать часть из них.


const N=30;
var a: array [l..N] of integer;
i,j,s: integer;
begin
for i:=l to N do readln(a[i]);
...
end.

дан целостный массив из 30 элементов. элементы массива могут принимать целые значения от 0 до 100 опишите на русском языке или одном из языков

программирования алгоритм позволяющий найти и вывести номер элемента массива имеющего максимальное значение сре элементов массива которые делятся на 3 и кратны 5

Дан целочисленный массив из 10 элементов.Элементы массива могут принимать целые значения от -50 до 50.Составить программу ,позволяющую найти и

вывести сумму элементов массива которые кратны 7 и оканчиваются на 5 .Гарантируется,что в исходном массиве есть хотя бы один такой элемент.
НА ЯЗЫКЕ ПАСКАЛЬ!!!!

ПАСКАЛЬ.1)дан целочисленный массив из 30 элементов.элементы массива могут принимать целые значения от 0 до 1000.опишите на русском языке или на одном из

языков программирования алгоритм,позволяющий найти среднее арифметическое нечетных трехзначных чисел,записанных в этом массиве.если ни одного такого числа нет,нужно вывести сообщение об этом.
2)дан целочисленный массив из 30 элементов.элементы массива могут принимать целые значения от 0 до 100.опишите на русском языке или на одном из языков программирования алгоритм,позволяющий найти и вывести произведение элементов массива,которые имеют четное значение и не оканчиваются на 0.



Вы находитесь на странице вопроса "Вывести все элементы массива кратные 3, помогите пожалуйста с кодом", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.