Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Написать программу нахождения N-го члена ряда Фибоначчи.

5-9 класс

Tyytr 08 авг. 2016 г., 3:51:52 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Lalala1993
08 авг. 2016 г., 4:57:59 (7 лет назад)

var
a: array[1..100] of real;
n, i: integer;

begin
readln(n);
a[1] := 1;
a[2] := 1;
for i := 3 to n do
a[i] := a[i - 1] + a[i - 2];
writeln(a[n]:15:0);
end.

Ответить

Читайте также

Помогите написать программу для Паскаля.

1. Написать программу нахождения произведения n чисел.

Написать программу,которая вычисляет сумму первых n членов ряда 1,3,5,7. Количество суммируемых членов ряда задаётся во время роботы программы.

(ниже представлен рекомендуемый вид экрана во время работы программы)
Вычисление частичной суммы рада 1,3,5,7.
Введите количество суммируемых членов ряда: 15
Сумма первых 15 членов ряда равна 330.

1. Даны два различных вещественных числа X и Y. Написать программу, возведения наименьшего из чисел в квадрат, наибольшего – в куб и нахождения среднего

арифметического полученных значений.
2. За весну Обломов похудел на p1 кг, за лето поправился на p2 кг, за осень похудел на p3 кг, за зиму поправился на p4 кг. Написать программу, определяющую, похудел или поправился за год Обломов.
3. Написать программу, которая определяет, является ли целое число четным двузначным числом.
4. Даны коэффициенты квадратного уравнения. Написать программу, определяющую его корни

помогите пожалуйста..очень надо....что нибудь из этих задач..1)написать программу которая поменяет местами первую и последнюю букву в слове. 2)написать

программу которая вставит между буквами веденного слова пробелы 3)написать программу вывода на экран деление двух чисел

5-9 класс информатика ответов нет
Паскаль ABC 1.Написать программу рисующую вертикальную цепочку из 7 кругов 2.Написать программу рисующую цепочку из 5 кругов

расположденных по диагонали

3.Написать программу рисующую горизонтальную цепочку из 12 кругов,каждый круг должен на половину закрывать предыдущий

Помогите,а то сижу с паскалем уже час с лишним и все никак не получается..

Заранее спасибо)



Вы находитесь на странице вопроса "Написать программу нахождения N-го члена ряда Фибоначчи.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.