Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Написать инструкцию вывода значения переменной a (тип real) с тремя цифрами в дробной части.

5-9 класс

Lenochka6 07 мая 2015 г., 6:53:47 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Svetik401
07 мая 2015 г., 9:30:33 (9 лет назад)

Формат вывода числа a
a:4:3
где a - это само число, 4 - кол-во выделяемых на вывод числа символов, 3 - длина дробной части (числа могут быть любыми).

Например, вывод числа:
writeln('Chislo a ravno ', a:4:3);

Ответить

Другие вопросы из категории

СРОЧНО ПОМОГИТЕ ПОЖАЛУЙСТА

нужно сделать к этой задаче блог схему(ну там ромб,параллелограмм) просто я в этом плохо понимаю

мальчик учит стихотворение из 40 строк. чтобы запомнить первую строчку надо 1 мин.на каждую следующую он тратит на 10% времени больше. стихотворение

держится в памяти не дольше 3 часов. а до школы бежать 15 минут. как организовать заучивоние стихотворения?

решить желательно в EXCEL

Читайте также

A01: Что изменяет операция присваивания? 1) значение переменной 2) имя переменной

3) тип алгоритма

4) тип переменной

5) не изменяет ничего

A02:

Переменная в программировании считается полностью заданной, если известны ее:

1) тип, имя

2) имя, значение

3) тип, значение

4) значение

5) тип, имя, значение

A03:

Чему будут равны значения переменных X, Y и Z после выполнения фрагмента программы на Паскале?

X := 5; Y:= 3; Z := X*Y; Y: = Y–X; X := X+ Y; Z := 4*Z+X

1) X = 5; Y = 3; Z = 12

2) X = 3; Y = –2; Z = –12

3) X = 3; Y = –2; Z = –63

4) X = 3; Y = –2; Z = 63

5) X = 5; Y = 3; Z = 15

A04:

Выбрать оператор присваивания с ошибкой: 1) SKOLA:=A/B 2) FF3A:=3*B/C+D 3) X:=(Y+1)(X+1) 4) M:=((2+2))–5 5) K54:=D9876

A05:

Выбрать арифметическое выражение, соответствующее формуле


1) X/(A*B)+Y*B/A

2) X/A*(B+Y)*B/A

3) X/A*(B+Y*B/A)

4) X/(A*B)+(Y*B)/A

5) X/A*B+Y*B/A

A06:

Выбрать последовательность команд, меняющих местами две величины X и Y.

1) X := Y; Y := X

2) X := A; X := Y; A := Y

3) X := Y

4) A := X; X := Y; Y := A

5) X := A; Y := X; A := Y

A07:

Чему будет равно значение переменной S после выполнения фрагмента программы на Паскале?

A := 2; B := 3;

IF A<B THEN S:=A*B ELSE S:=A+B;

WRITE (S);

1) 2

2) 6

3) 5

4) 3

5) 11

A08:

Выбрать фрагмент программы на Паскале, в котором переменной Y присваивается значение, равное 0, если –5 < X <5. в противном случае переменной Y присваивается значение, равное 1.

1) Y := 1; IF X > –5 ТHEN IF X < 5 THEN Y := 0;

2) IF X > –5 ТHEN IF X < 5 THEN Y := 0 ELSE Y := 1;

3) IF X < –5 ТHEN IF X > 5 THEN Y := 1 ELSE Y := 0;

4) IF X > –5 ТHEN IF X < 5 THEN Y := 0; Y := 1;

5) IF X > –5 ТHEN Y := 0 ELSE Y := 1; IF X < 5 THEN Y := 1;

A09:

Чему будет равно значения переменной S после выполнения фрагмента программы на Паскале?

S := 0; i := 0;

WHILE i<3 DO

BEGIN

i := i + 1;

S := S + i*i;

END;

1) S = 0

2) S = 6

3) S = 10

4) S = 14

5) S = 18

A10:

Какое значение нужно ввести при исполнении программы, чтобы в результате было выведено значение 128?

var i,n,p : integer;

begin write ('Введите n ');

readln (n);

p:=1;

for i:=0 to n do

p:=p*2;

write (p);

end.

1) n = 6

2) n = 8

3) n = 16

4) n = 32

5) n = 64

A11:

Чему будет равно значения переменной S после выполнения фрагмента программы на Паскале?

a := 1; b := 1;

WHILE a+b<10 DO

BEGIN

a := a + 1;

b := b + a;

END;

s := a + b;

1) S = 0

2) S = 6

3) S = 10

4) S = 14

5) S = 18

A12:

Чему будут равны значения переменных S и i после выполнения фрагмента программы на Паскале?

S := 0; i := –2;

WHILE i < 2 DO

BEGIN

i := i+1;

IF i:=0 THEN А:=1 ELSE A:=1/ i;

S:=S+A;

END;

1) S = 1.5; i = 2

2) S = 1; i = 2

3) S = 0.5; i = 2

4) S = 1; i = 1

5) S = 0.5; i = 1

A13:

Чему будет равно значения переменной S после выполнения фрагмента программы на Паскале?

S := 128;

FOR i := 1 TO 4 DO S := S – 3;

1) S = 112

2) S = 116

3) S = 124

4) S = 16

5) S = 125

A14:

Чему будет равно значения переменной d после выполнения фрагмента программы на Паскале?

var x,y,d : integer;

begin x:=5; y:=2;

if (y>x+2) or (y>0)

then d:=x+2

else d:=y-x;

write(d);

d:=10;

end.

1) d = 2

2) d = 3

3) d = 5

4) d = 7

5) d = 10

A15:

Чему будет равно значения переменной S после выполнения фрагмента программы на Паскале?

FOR i := 1 TO 3 DO

BEGIN

S := 0;

FOR j := 2 TO 2 DO

S := i + j;

END;

1) S = 0

2) S = 6

3) S = 5

4) S = 12

5) S = 10

A16:

Чему будут равны значения переменных S и i после выполнения алгоритма?

S := 0; i := –3;

ПОКА i < 2 ПОВТОРЯТЬ

ЕСЛИ i < 0 ТО А := i * i ИНАЧЕ А := i – 1 КОНЕЦ ВЕТВЛЕНИЯ

S := S + А;

i := i + 1;

КОНЕЦ ЦИКЛА

1) S = 1; i = 1

2) S = 13; i = 2

3) S = 14; i = 2

4) S = 2; i = 2

5) S = 13; i = 1

A17:

Выбрать фрагмент алгоритма, позволяющий найти максимальное из трех чисел x, y, z.

1) ЕСЛИ x > y ТО b := x КОНЕЦ ВЕТВЛЕНИЯ b := y ЕСЛИ b < z ТО b := z КОНЕЦ ВЕТВЛЕНИЯ

2) ЕСЛИ x > y ТО b := x ИНАЧЕ b := y КОНЕЦ ВЕТВЛЕНИЯ ЕСЛИ b > z ТО b := z КОНЕЦ ВЕТВЛЕНИЯ

3) ЕСЛИ x > y ТО b := x ЕСЛИ b < z ТО b := z ИНАЧЕ b := y КОНЕЦ ВЕТВЛЕНИЯ КОНЕЦ ВЕТВЛЕНИЯ

4) ЕСЛИ x > y ТО b := x ИНАЧЕ ЕСЛИ b < z ТО b := z ИНАЧЕ b := y КОНЕЦ ВЕТВЛЕНИЯ КОНЕЦ ВЕТВЛЕНИЯ

5) ЕСЛИ x > y ТО b := x ИНАЧЕ b := y КОНЕЦ ВЕТВЛЕНИЯ ЕСЛИ b < z ТО b := z КОНЕЦ ВЕТВЛЕНИЯ

A18:

Чему будет равно значения переменной Y после выполнения программы на Паскале, если было введено 4?

var X, Y: integer;

begin

read (X);

X:=X*10;

if X>40 then Y:=X+5

else if X=40 then Y:=X*5

else begin Y:=X+10; Y:=Y*2 end;

write (Y);

end.

1) Y = 40

2) Y = 45

3) Y = 50

4) Y = 100

5) Y = 200

Подробности от учителя:1.Определить значение переменной у после выполнения следующего фрагмента программы:

y:=1;
For i:=2 to 4 do y:=y+i;

2.Определить значение переменной у после выполнения следующего фрагмента программы:
y:=0;
For i:=-100 to 100 do
If i mod 10 =5 then y:=y+i;

3. На промежутке [a;b] (a,b -целые числа, которые вводятся с клавиатуры) определить среднее арифметическое чисел кратных 7

1.Какое значение переменной S будет напечатано после выполнения фрагмента программы,записанной на языке программирования TURBO PASCAL:A:=2В: = 3;

if A>B then S: = A+B;
writeln (S);
Варианты ответов:1)5 ;2)6; 3)7; 4)8

2. Какое значение переменной S будет напечатано после выполнения фрагмента программы, записанной на языке программирования PASCAL:
S: =1;
N: =1;
while N<=3 do
begin
S: = S*N;
N: = N+1;
end;
writeln(S);
Варианты ответов: 1)2 ; 2)1; 3)0; 4)4



Вы находитесь на странице вопроса "Написать инструкцию вывода значения переменной a (тип real) с тремя цифрами в дробной части.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.