Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

С ПОМОЩЬЮ ПАСКАЛЯ!

5-9 класс

1. Задано число x. Найдите s, если:
s = cos x - sin x + |x-7| + x2 - 1
2.Даны два действительные числа.
Найти среднее арифметическое этих
чисел.
3.

Lilia200427 04 февр. 2017 г., 3:04:40 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Dgasmina2004
04 февр. 2017 г., 5:46:50 (7 лет назад)

1)
var x,s:real;
begin
readln(x);
s:=cos(x) - sin(x) + abs(x-7) + x*x - 1;
writeln (s)
end.

2)
var x,y,s:real;
begin
readln(x,y);
s:=(x+y)/2;
writeln(s)
end.

3)
var x,y:real;
begin
readln(x);
if x<0 then y:=x*x-5;
if x=0 then y:=3;
if x>0 then y:=x-3;
writeln(y)
end.

+ 0 -
Даша554
04 февр. 2017 г., 7:02:52 (7 лет назад)

x2 - это х в квадрате или х*2?

+ 0 -
АринаДробахина
04 февр. 2017 г., 9:54:21 (7 лет назад)

в квадрате

Ответить

Другие вопросы из категории

Задача на Паскале.

Задан массив случайным образом. Преобразовать его след. образом:

решить задачу x2+3\60-4\48- где x =3
день-ночь превратить из 4 слов

Читайте также

Помогите, с помощью паскаля надо сделать следующее:

Составить программу, решающую следующую задачу: дано трехзначное число. В нем зачеркнули первую цифру слева и приписали ее справа. Вывести полученное число.
Так же:
Составить программу, решающую следующую задачу: дан номер некоторого года (целое положительное число). Определить соотв-щий ему номер столетия, учитывая, что, к примеру, началом 20го столетия был 1901 год. Сам то я знаю как решать, но не смогу записать это в паскаль!

Помогите решить задачи с помощью Паскаля:

1. В массиве все отрицательные элементы переместить в начало массива, а остальные в конец с сохранением порядка следования.
2. Дана последовательность целых чисел, среди чисел есть одинаковые, создать массив различных чисел последовательности и полученный массив отсортировать по возрастанию.

Решить задачи с помощью Паскаля:

1. Заполнить массив из 10 элементов случайными числами в интервале [0..100] и отсортировать его по последней цифре.
2. Заполнить массив из 10 элементов случайными числами в интервале [0..100] и отсортировать первую половину по возрастанию, а вторую- по убыванию. Здесь решать лучше методом выбора.



Вы находитесь на странице вопроса "С ПОМОЩЬЮ ПАСКАЛЯ!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.