Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Задача на Паскале.

5-9 класс

Задан массив случайным образом. Преобразовать его след. образом:

General2003 26 янв. 2017 г., 23:51:36 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
YlaGV30
27 янв. 2017 г., 0:56:00 (7 лет назад)

uses crt;
var a:array[1..10] of integer;
i:integer;
begin
writeln('Исходный массив:');
for i:=1 to 10 do begin
a[i]:=random(10-(-10)+1)-10;
write(a[i]:3);
end;
writeln;
for i:=1 to 10 do begin
if a[i]>0 then a[i]:=a[i]*2;
if a[i]=0 then a[i]:=10;
if a[i]<0 then a[i]:=abs(a[i]);
write(a[i]:3);
end;
end.

 

Здесь массив сделан из 10 чисел от -10 до 10. 

 

 

 

 

+ 0 -
Володя2001
27 янв. 2017 г., 2:17:42 (7 лет назад)

Program t1;
Var
a: array [1..100] of integer;
i: byte;
begin
for i:=1 to 100 do
begin
readln (a[i]);
end;
for i= 1 to 100 do
begin
If (a[i]<0) then
a[i]= abs(a[i]);
If (a[i]>0) then
a[i]= a[i]*2;
If (a[i]=0) then
a[i]= 10;
end;
end.

Ответить

Читайте также

Помогите решить задачки на паскале я совсем не разбираюсь в этом!!! 1)Дана таблица со значениями среднемесячных температур в течение года. Составить

программу на Паскале, в которой вычисляются четыре величины: средние температуры зимних месяцев, весенних месяцев, летних и осенних. 2)Вы посетили магазин и купили 10 видов товара. В таблицу T [1..10] записали количество купленного товара каждого вида. В таблицу C [1..10] записали цену единицы каждого вида товара соответственно. Составить программу на Паскале вычисления общей стоимости всех покупок.

Найти алгоритм минимума из 3х целых чисел на паскале+ составить блок -схему.

ПОЖАЛУЙСТА,ХОТЯ БЫ НА ПАСКАЛЕ СОСТАВЬТЕ!

1)Как можно описать на Паскале 1)Как можно описать на Паскале массив,в котором будет храниться значения численности населения Москвы к концу

каждого года XX века?
2)Вы приобрели котёнка.Каждый вечер вы определяете его вес с помощью весов.Как можно описать на Паскале массив,в котором будет храниться значения веса котёнка в течение месяца (например,мая)?

Люди очень срочно решите пожалуйста задачу на Паскале:

их 4 штуки!
1.дан массив тз N элементов. Есть ли в нем чётные элементы, которые кратны заданному числу K.
2. Дан массив из Nэлементов. Посчитать, сколько элементов массива равных минемальному.
3. Сформировать массив из Nэлементов: 10 12 16 22 30 40.
4. Дан массив из Nэлементов. Перемножить минемальные элементы на 2.
Heeelp!



Вы находитесь на странице вопроса "Задача на Паскале.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.