Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Найдите сумму натуральных нечетных чисел не превышающих n!Сделать циклм while

10-11 класс

Dino4ek1 01 мая 2013 г., 12:57:23 (11 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
SERAYU
01 мая 2013 г., 13:32:34 (11 лет назад)

var i,n,sum:integer;

Begin

  read(n);

  i:=1;

  sum := 0;

  while i<=n do

  begin

     sum := sum + i;

     i := i + 2;

  end;

write(sum);

end.

Ответить

Другие вопросы из категории

Какая из технологий обеспечивает наибольшую плотность записи информации?

1) DVD

2) CD-ROM

3) RAID

4) DLT

5) Магнитооптическая

ПОМОГИТЕ ПОЖАЛУЙСТА!!!

Напишите программу, которая вводит радиус круга и вычисляет площадь этого круга и длину окружности. На языке Паскаль можно использовать встроенную константу Pi, равную числу .

Читайте также

1)Найдите сумму натуральных нечетных чисел не превышающих n!!!!Это нужно сделать циклом for. 2) Составьте программу,которая производит

суммирование произвольного количества целых чисел вводимых с клавиатуры.Концом последовательности служит ввод отрицательного числа.Программу составьте двумя способами: использую цикл с предусловием и цикл с постусловием

Напишите программу, которая в последовательности целых чисел определяет их количество и подсчитывает сумму положительных чётных чисел, не превосходящих

256. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести два числа: длину последовательности и сумму положительных чётных чисел, не превосходящих 256.



Вы находитесь на странице вопроса "Найдите сумму натуральных нечетных чисел не превышающих n!Сделать циклм while", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.