Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Паскаль

1-4 класс

1-Дано : массив целых чисел А[N]. Проверьте , есть ли в нем элементы равные нулю. Если есть, то найдите номер первого из них, те наименьшее i, при котором А[i]=0, иначе выведите сообщение.
2- Из заданной строки выбрать и напечатать все слова начинающиеся с буквы "А".

SPAK 14 марта 2014 г., 17:50:45 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Дахутка
14 марта 2014 г., 19:23:06 (10 лет назад)

1)
program gt;
var a:rray[1..10000]of integer;
n,i,q,l:integer;
begin
read(n);
q:=0;
for i:=1 to n do
begin
read(a[i]);
if(a[i]=0)then begin
q:=q+1;
if(q=1)then l:=i;
end;
end;
if(q>1)then writeln(l) esle writeln('false');
end;
2)
program gt;
var s,a:string;
b:array[1..100]of string;
l,i,k:integer;
begin
readln(a);
l:=length(a);
k:=0;
for i:=1 to l do
begin
if(a[i]=' ')then begin
k:=k+1;
b[k]:=s;
s:='';
end;
if(a[i]<>' ')then s:=s+a[i];
end;
for i:=1 to k do
begin
if(b[i][1]='a')then writeln(b[i]);
end;
end.

Ответить

Читайте также

Даны числа: x, y. Вычислите: z=x+y, если

x \leq y, и z=x-y в противном случае.

Написать программу в паскале.

Коллеги помогите !!!!!!!!!!

Впиши в таблицу имена и свойства объектов. Учёный Паскаль Талантливый.

---------- Шишкин ----------------
Композитор ---------- -----------
Озеро ----------- ----------------
------------ Лондон ---------------
----------- ------------ --------------

8 класс Паскаль номер 5 а) б)


Вы находитесь на странице вопроса "Паскаль", категории "информатика". Данный вопрос относится к разделу "1-4" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.