Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

В строке записанно целое число.При записи этого числа была допущена опичатка: среди цифр находятся посторонние символы.Исправьте строку с опичаткой,

10-11 класс

удалите лишний символ.

Arina9820 09 февр. 2017 г., 2:33:30 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ирина1234Дольчук
09 февр. 2017 г., 4:11:17 (7 лет назад)

var s:string;i:integer;
begin
i:=1; read(s);
while i<=length(s) do if (s[i]<'0') or (s[i]>'9') then delete(s,i,1) else i:=i+1;
write(s)
end.

Ответить

Другие вопросы из категории

конструкция IF< условие >THEN <действия 1> описывает:

a) полное ветвление
b) вывод на экран условия
c) неполное ветвление

Турбо паскаль:

Вводится строка и символ. Определить количество
слов, содержащих введенный символ.

Помогите срочно!!!.

Формальной информационной моделью является ...
А) анатомический муляж;
Б) техническое описание компьютера;
В) рисунок функциональной схемы компьютера;
Г) программа на языке программирования.
6. Компьютерный эксперимент может быть проведен, если информационная модель представлена в форме ...
А) программы на языке программирования;
Б) изображения в растровом графическом редакторе;
В) изображения в векторном графическом редакторе;
Г) текста в текстовом редакторе.

помогите,пожалуйста!!!

Упростить логическое выражение:
x ^ y ^ z v -x ^ -y ^ -z v x

Читайте также

Автомат получает на вход два двузначных шестнадцатеричных числа . В этих числах все цифры не превосходят цифру 6 (если в числе есть цифра больше 6,

автомат отказывается работать). По этим числам строится новое шестнадцатеричное число по следующим правилам. 1) Вычисляются два шестнадцатеричных числа – сумма старших разрядов заданных чисел и сумма младших разрядов этих чисел . 2) Полученные два шестнадцатеричных числа записываются друг за другом в порядке возрастания (без разделителей). Пример. Исходные числа: 66, 43. Поразрядные суммы: A, 9. Результат: 9A. Определите, какое из предложенных чисел может быть результатом работы автомата : 1) AF 2) 410 3) 8B 4) 76 (и объясните, пожалуйста, как это решать вообще)) )

Срочно! Дано трехзначное число. Если сумма цифр этого числа превышает 15, то вывести эту сумму. Иначе вывести

произведение цифр этого числа.

Необходимо решение на языке Паскаль. Заранее спасибо!

ЕГЭ 2012. А5. Автомат получает на вход два двузначных восьмеричных числа. По этим числам строится новое восьмеричное число по следующим

правилам.

1. Вычисляются два восьмеричных числа – сумма старших разрядов заданных чисел и сумма младших разрядов этих чисел.

2. Полученные два восьмеричных числа записываются друг за другом в порядке убывания (без разделителей).

Пример. Исходные числа: 66, 24. Поразрядные суммы: 10, 12. Результат: 1210.

1) 112

3) 129

Объясните пожалуйста пример, почему они так складывают, разве не так: 6+2 и 6+4 ? И почему не подходит 3 вариант.

Разделите точками цифры этого числа группами по три , начиная справа.

Программа получает на вход натуральное число , содержащее не более 100 цифр.
Программа должна вывести то же число , с точками между некоторыми цифрами этого числа.

Примеры входных и выходных данных

Ввод 1000 1.000
Вывод 12345678 12.345.678




Вы находитесь на странице вопроса "В строке записанно целое число.При записи этого числа была допущена опичатка: среди цифр находятся посторонние символы.Исправьте строку с опичаткой,", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.