Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Задана строка S требуется подсчитать кол-во включений подстроки PS1 в строке S и заменить на подстроку PS2

10-11 класс

пвроваамакрлоекмащд 01 июля 2013 г., 16:13:27 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Kuklatanj
01 июля 2013 г., 17:40:59 (10 лет назад)

var s,p1,p2:string;
i,k:integer;
begin
readln(s);
readln(p1);
readln(p2);
while (pos(p1,s)>0) do begin
inc(k);
i:=pos(p1,s);
delete(s,pos(p1,s),length(p1));
insert(p2,s,i);
end;
writeln(k);
writeln(s);
end.

+ 0 -
Volkovaalisa
01 июля 2013 г., 19:39:11 (10 лет назад)

CРОЧНО

Ответить

Другие вопросы из категории

помогите пожалуйста.......
Помогите сделать эту задачу, у самого бред получается не шарю в я этом пытался сделать по аналогии другого варианта, но нечего не вышло не понимаю( вот

что вышло у меня:Program zzz;
uses ctr;
var
M:array [1..7] of integer;
i,sum:integer;
begin;
clrscr;
sum:=0;
writeln('Введите массивы: ');
for i:=1 to 7 do begin
read (M[i]);
sum:=sum+sqr(M[i]);
дальше незнаю как да и это полным бредом наверно покажется знающим людям. Учусь на 1 курсе в вузе, в школе информатики не было вообще. Отчитали лекции нам, посадили за компы, а я паскаль этот в первый раз и увидел на первом же занятии... Пытаюсь вникнуть но не особо получается. Прошу помощи)

Читайте также

Сумма цифр. Даны два числа А и В. Подсчитайте кол-во натуральных чисел на отрезке от А до В , сумма цифр которых четна. Программа

получает на вход два натуральных числа А и В, не превосходящих 10^9^ А<=В . Программа должна вывести одно число - кол-во натуральных чисел, больше или равных А и меньших или равных В, сумма цифр которых четна.

10 КЛАСС! ПАСКАЛЬ АБС!! СРОЧНО!! ПОМОГИТЕ ПОЖАЛУЙСТА! Дан массив А(n). Опередлите кол-во нечет элементов массиава, стоящих на

четных местах. выведите на экран исходный массив и найденное кол-во.

Помогите, пожалуйста, разобраться и составить верный алгоритм. В задаче требовалось написать программу на Паскале и сравнить её с приведенной в учебнике.

"Подсчитайте кол-во операций в приведенном алгоритме (Ответ приведите в виде функции от параметра n)." Подсчитать кол-во операций самому - это возможно, а как привести ответ в виде функции от параметра n - я не знаю. Помогите, пожалуйста, понять это задание. Заранее благодарен!



Вы находитесь на странице вопроса "Задана строка S требуется подсчитать кол-во включений подстроки PS1 в строке S и заменить на подстроку PS2", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.