Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

даны целые числа а,в,с.Написать программу ,подчитывающую количество положительных и количество отрицательных чисел среди данных

10-11 класс

Эмма1997 07 июля 2014 г., 0:02:59 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ася76Аська
07 июля 2014 г., 1:38:44 (9 лет назад)

Program Z_n;
var a,b,c,d,d1:integer;
Begin
Readln(a,b,c);
If a>=0 then d:=d+1
else d1:=d1+1;
If b>=0 then d:=d+1
else d1:=d1+1;
If c>=0 then d:=d+1
else d1:=d1+1;
Writeln('Положительный чисел:',d);
Writeln('Отрицательных чисел:', d1);
end.

Ответить

Другие вопросы из категории

Помогите,пожалуйста:

1.Перевести в двоичную систему счисления :7756;4258;5568.
2.Перевести в десятичную систему счисления:100101,001(2);101111,1101(2);10101,01(2)
3.Выпишите целые десятичные числа ,принадлежащие следующему промежутку [101101(2),110000(2)]
4.В классе 1111(2)-девочек и 1100(2)-мальчиков .Сколько учеников в классе.Ответ в двоичной системе счисления.

1.Для объекта задан эффект «Выход». Что произойдет с объектом

после окончания анимации?

1 как называется диск. накопитель,

с которого загружается операц.система?
а boot drive
b boot diskette
c boot partition
2 название формата графич. изображ., используемого в ос windows
a pdf
b xml
c bmp
3 название начальной записи на диске, где записана информация необходимая ос для работы с диском
a bootstrap
b boot partition
c boot-sector
4программа wine предназначена для выполнения функции:
а для настройки и запуска ssh-сервера
b для запуска windows-программ в ос Linux
c для запуска эмулятора virtual box
d для запуска VMware
e для запуска граф. интерфейса gnome os Linux
5 порция информации, оставляемая на компьютере веб-клиента программой, запущенной на стороне веб-сервера. применяется для сохранения данных, специфичных для данного клиента.
a вирус-шпион trojan-spy.win32
b cookie
c вирус блокиратор программ-браузеров
d вирус баннер
6 как называется стандарт памяти и технология,приводящие к удвоению скорости передачи данных между памятью и процессором?
а dds
b dec
c ddr
d dsl
7как называется программный компонент, который позволяет взаимодействовать с устройствами компьютера
а dsl
b dream weaver
c deriver
d dynamic languages
8как называется информационный барьер, запрещающий доступ к защищаемой сети всех протоколов кроме разрешеных
a flash
b firewall
c file fragmentation
d fire wire
9 протокол передачи данных между компьютерами. в качестве транспортного механизма для передачи используется протокол tct
a Bluetooth
b wifi
c ftp
d irDA
12. как называется стандарт интерфейса в беспроводной связи?
а ieee
b ieee 802.11
c igmp
d ieee 802.11 b/g/n
14 назовите программу для создания презентации, аналог powerpoint mo
a draw
b impress
c math
d base
17 технология преобразования множества внутренних ip адресов сети в внешние адреса, используемые для связи с Интернет?
a dns
b http
c nat
d ip v4
18. в этих аккумуляторах вместо ядовитого кадмия применяются соединения металлов с водородом
а li-ion soni Ericsson
b li-полимерные Nokia
c никель-металлогидридные gp
20 какая программа, расширяет возможности какого-нибудь программного пакета
a playlist
b plug-in
c portable soft
d pe - file
21 специальный формат файлов, разработанный корпорацией Microsoft для обмена форматированными текст.документами
a txt
b djvu
c rtf
d pdf
e fb2
22 как называются разъемы для установки на системную плату различных типов процессоров семейств 486, pentium и pentium pro
a sosket 7
b sosket 478
c sosket 1-8
d sosket 486
23 какая программа не является эмулятором ос
а qemu
b virtual box
c moba liveCD
d VMware player
g wine
24 какую функцию осуществляет файл с расширением vmdk
a описание параметров виртуального жесткого диска
b главный конфигурац. файл виртуальной ос
c постоянная память ram
d файл подкачки виртуальной машины
25 какой оценочный период установлен, для пользователя, в компьютерной программе Microsoft virtual pc 2007
a бесплатное пользование 30 дней
b бп 60 дней
c бп 10 дней
d период пользования не установлен
е требуется оплата при установки

Читайте также

Задачи паскаль, помогите пожалуйста кто. 1, Напишите программу, реализующую следующие вычисления. Дан номер месяца — целое число в диапазоне

1–12, введенное с клавиатуры (1 — январь, 2 — февраль и т. д.). Вывести название соответствующего времени года («зима», «весна», «лето», «осень»).

2, Напишите программу, реализующую следующие вычисления. Дана матрица размера M x N (числа вводятся с клавиатуры). Для каждого столбца матрицы найти произведение его элементов. Полученные значения вывести в текстовый файл.

3, Напишите программу с использованием функции CircleS(R) вещественного типа, находящей площадь круга радиуса R (R — вещественное). С помощью этой функции найти площади трех кругов с данными радиусами. Площадь круга радиуса R вычисляется по формуле S = πR2.

4, Напишите программу, реализующую следующие вычисления. Дано целое число N (1≤N≤26), введенное с клавиатуры. Вывести N первых прописных (то есть заглавных) букв латинского алфавита.

помогите написать программы

1. Дано целое число N (> 0). Если N — нечетное, то вывести произведение 1•3•...•N; если N — четное, то вывести произведение 2•4•...•N.
2. Вывести на экран таблицу значений функции x2 на отрезке[0,1] с шагом 0.1.

Помогите исправить ошибки и написать блок-схему. Задание: Имеется массив А из N произвольных чисел, среди которых есть положительные,

отрицательные и равные нулю. Используя оператор цикла, составить программу, вычислить количество положительных и нулевых и сумму отрицательных.

Листинг программы:

Program Massiv;

Const n=10;

Var A:array [1..4] of integer;

I, c, c2, c3: integer;

Begin

For i=1 to N do begin

Readln (a[i]); If (a[i]=0 then inc(c)

Else if ([ai]<0) then inc(c2)

Else inc (c3);

End;

Writeln (`нулевые:`,c);

Writeln (`отрицательные:`,c2);

Writeln (`положительные:`,c3);

End.

Дана строка , в которой содержится осмысленное текстовое сообщение. Слова сообщения разделяются В заданном формате дд- целое число из диапазона от 1 до

31, мм - целое число из диапазона от 1 до 12, а гг - целое число из диапазона от 1 до 2020 (если какая-то часть формата нарушена, то данная подстрока в качестве даты не рассматривается.) Заменить каждую дату сообщения на дату следующего дня. Написать программу на Паскале. Сроооооооооооооочнооо. Пооожалуйста.....

10-11 класс информатика ответов нет


Вы находитесь на странице вопроса "даны целые числа а,в,с.Написать программу ,подчитывающую количество положительных и количество отрицательных чисел среди данных", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.