Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Помогите пожалуйста с программой..(в Паскале)

10-11 класс

Составить программу табулирования функции заданной рекурентной формулой.
f(0)=1; f(1)=2; f(n+2)=2*f(n+1)-n

Sera3576 16 окт. 2013 г., 20:43:26 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Q42
16 окт. 2013 г., 22:14:52 (10 лет назад)

function f(n:integer): integer;
begin
  if n=0 then f := 1
  else if n=1 then f := 2
  else f := 2*f(n-1)-n+2;
end;


var n: integer;
begin 
  writeln('n':5, 'f(n)':10);
  for n := 0 to 20 do
    writeln(n:5, f(n):10);  
end.

Ответить

Другие вопросы из категории

Задача F Оплата Сегодня Али в местном магазине сделал покупку за C тенге. Он только хотел расплатится и услышал от прод

авца фразу "Без сдачи пожалуйста, молодой человек". У него есть всего N монет достоинств a1, a2, ..., aN тенге. Определите, сможет ли он расплатится без сдачи.

Формат входных данных

В первой строке входного файла записаны два целых числа C (1 ≤ C ≤ 1000) и N (1 ≤ N ≤ 15) — общая сумма покупки и количство монет у Али соответсвенно. Во второй строке записаны N целых чисел a1, a2, ..., aN (1 ≤ ai ≤ 1000)— достоинства монет Али.

Формат выходных данных

В единственной строке выведите слово «YES», если Али сможет расплатится без сдачи. Иначе, выведите «NO»

Заданное число M из диапазона 0.. 109. перевести в

троичную систему счисления . Число M хранится в
входном файле Exch.in, его представление в троичной
системе счисления сохранить в выходном файле
Exch.out.

Y= \left \{ {{\sqrt{|x^{2}-2|}} \atop {ln|x|}} \right

Читайте также

Здравствуйте, уважаемые :) Помогите пожалуйста составить программу на Паскале. Спасибо огромное!

1. Напишите программу формирования и вывода массива размером 6x3, каждые три последовательных элемента в строке которого составлены по следующему правилу:
1-й — равен случайному числу;
2-й — равен целой части квадратного корня из предыду щего элемента;
3-й-равен сумме двух предыдущих элементов.

Помогите пожалуйста написать программу в паскале.

Составить программу перевода натурального числа из десятичной системы счисления в двоичную

10-11 класс информатика ответов нет
Помогите пожалуйста...Напечатать программу в паскале...Срочно...Завтра последний срок сдачи..

Дан массив строк без пробелов. Напечатать строки, вторая половина которых не содержит цифры.



Вы находитесь на странице вопроса "Помогите пожалуйста с программой..(в Паскале)", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.