Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

дан одномерный массив С (10) заполненный вручную с клавиатуры,отсортировать по возрастанию и убыванию.

10-11 класс

Pefugi 23 окт. 2013 г., 19:54:28 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vfhujif
23 окт. 2013 г., 22:23:42 (10 лет назад)

var   
c:array[1..100] of integer; 
s,j,n,i:integer;
begin   
readln(n);  
for i:=1 to n do       
read(c[i]); 
//Сортировка по возрастанию 
for j:=1 to n-1 do   
for i:=1 to n-j do     
if c[i]>c[i+1] then     
begin       
s:=c[i];       
c[i]:=c[i+1];       
c[i+1]:=s;     
end;
//Вывод  
for i:=1 to n do     
write(c[i],' ');
writeln;
//Сортировка по убыванию 
for j:=1 to n-1 do   
for i:=1 to n-j do     
if c[i]<c[i+1] then     
begin       
s:=c[i];       
c[i]:=c[i+1];       
c[i+1]:=s;     
end;
//Вывод  
for i:=1 to n do     
write(c[i],' ');  
end.

Ответить

Другие вопросы из категории

Помогите пожалуйста с программой..(в Паскале)

Составить программу табулирования функции заданной рекурентной формулой.
f(0)=1; f(1)=2; f(n+2)=2*f(n+1)-n

Задача F Оплата Сегодня Али в местном магазине сделал покупку за C тенге. Он только хотел расплатится и услышал от прод

авца фразу "Без сдачи пожалуйста, молодой человек". У него есть всего N монет достоинств a1, a2, ..., aN тенге. Определите, сможет ли он расплатится без сдачи.

Формат входных данных

В первой строке входного файла записаны два целых числа C (1 ≤ C ≤ 1000) и N (1 ≤ N ≤ 15) — общая сумма покупки и количство монет у Али соответсвенно. Во второй строке записаны N целых чисел a1, a2, ..., aN (1 ≤ ai ≤ 1000)— достоинства монет Али.

Формат выходных данных

В единственной строке выведите слово «YES», если Али сможет расплатится без сдачи. Иначе, выведите «NO»

Заданное число M из диапазона 0.. 109. перевести в

троичную систему счисления . Число M хранится в
входном файле Exch.in, его представление в троичной
системе счисления сохранить в выходном файле
Exch.out.

Y= \left \{ {{\sqrt{|x^{2}-2|}} \atop {ln|x|}} \right

Читайте также

Паскаль помогите пжл!!!!!! Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива,

расположенных между максимальным и минимальным элементами.

Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива, расположенных между максимальным по модулю и минимальным по модулю элементами

ну или исправьте мое пжл

program fgf;
var mas:array[1..100] of real;
max,min:real;
i,n,c,b:shortint;
p:real;
f1,g:text;
begin;
assign (f1, 'input.txt');
reset (f1);
readln (f1, n);

for i:=1 to N do read (mas[i]);
max:=mas[i];
for i:=2 to N do begin
if mas[i]>max then begin
max:=mas[i];
c:=i;
end;
end;
min:=mas[1];
for i:=2 to N do begin
if mas[i]<min then begin
max:=mas[i];
b:=i;
end;
end;
close(f1);
assign (g, 'output.txt');
rewrite (g);
p:=1;
if b<c then I:=b+1 and c-1

else for I:=c+1 to b-1 do p:=p*mas[i];

if (n<3) or (b+1=c) or (c+1=b) then writeln(g,'0.00') else write(p:3:3) ;

close (g);
end.

Дан одномерный массив целых чисел, заполненный

случайным образом числами из промежутка [-40, 30]. Массив данных хранится в
файле. Удалить из него все элементы, которые состоят из одинаковых цифр.
Результат записать в другой файл.

определить число элементов массива, больших К. По заданному условию сформировать одномерный массив, вывести на печать и произвести операции по обрабо

тке полученных компонентов массива. Исходными данными являются одномерный массив, элементы которого задаются с помощью датчика случайных чисел от -50 до +50 и целое положительное число К

Дан одномерный массив из 10 элементов. Элементы массива лежат в диапазоне от -20 до 20 и обозначают температуру первой декады (10 дней) марта. Определите

номера дней, когда температура опускалась ниже -10. Напишите программу, которая позволяет найти и вывести номера дней, когда температура опускалась ниже -10.



Вы находитесь на странице вопроса "дан одномерный массив С (10) заполненный вручную с клавиатуры,отсортировать по возрастанию и убыванию.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.