Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогите написать программу в паскали.Дан одномерный массив A[N]. Найти произведение четных чисел и сумму нечетных.

10-11 класс

12122001 08 июля 2014 г., 17:01:52 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ch97
08 июля 2014 г., 19:50:41 (9 лет назад)

const
  n = 5;

var
  a: array [1..n] of byte;
  s, k: longint;
  b: byte;

begin
  k := 1;
  for b := 1 to n do
  begin
    a[b] := random(1, 11);
    write(a[b]:3);
  end;
  
  writeln();
  
  for b := 1 to n do
    if (a[b] mod 2 = 1) then
      s := s + a[b]
    else
      k := k * a[b];
  
  for b := 1 to n do
    writeln(s, '    ', k);
end.

Ответить

Другие вопросы из категории

Программы сопряжения устройств компьютера называются:

a) загрузчиками;
b) драйверами;
c) трансляторами;
d) интерпретаторами;
e) компиляторами

Дан список наименований товаров с указанием их цен на начало года. Известен уровень инфляции в процентах для каждого месяца года (взять значения от 0,5 до

2%). Рассчитать цены каждого товара на 1-е число каждого месяца и конец года, компенсирующие потери от инфляционного процесса.

Читайте также

Паскаль помогите пжл!!!!!! Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива,

расположенных между максимальным и минимальным элементами.

Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива, расположенных между максимальным по модулю и минимальным по модулю элементами

ну или исправьте мое пжл

program fgf;
var mas:array[1..100] of real;
max,min:real;
i,n,c,b:shortint;
p:real;
f1,g:text;
begin;
assign (f1, 'input.txt');
reset (f1);
readln (f1, n);

for i:=1 to N do read (mas[i]);
max:=mas[i];
for i:=2 to N do begin
if mas[i]>max then begin
max:=mas[i];
c:=i;
end;
end;
min:=mas[1];
for i:=2 to N do begin
if mas[i]<min then begin
max:=mas[i];
b:=i;
end;
end;
close(f1);
assign (g, 'output.txt');
rewrite (g);
p:=1;
if b<c then I:=b+1 and c-1

else for I:=c+1 to b-1 do p:=p*mas[i];

if (n<3) or (b+1=c) or (c+1=b) then writeln(g,'0.00') else write(p:3:3) ;

close (g);
end.

Помогите написать программу в паскале. Задание:На плоскости даны 2 точки А (х1; у2) и В (х2; у2), определить какая из них находится дальше от начала коо

рдинат. Я поняла, что нужно найти их длины (формулы я знаю), а правильно написать программу не могу

Помогите написать программу на C#

Дано натуральное число n. Написать программу вычисляющую сумму

1)дан одномерный массив из 5 элементов.найти сумму положительных элементов. 2)Дан одномерный массив из 7

элементов.Найти колличество четных положительных элементов.

3)Дан массив из 6 элементов.Найти произвдение положительных из них.



Вы находитесь на странице вопроса "Помогите написать программу в паскали.Дан одномерный массив A[N]. Найти произведение четных чисел и сумму нечетных.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.