Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Помогите пожалуйста!!!!!! (Турбо паскаль, Условный оператор)

5-9 класс

Задача ;
Запрашивается стоимость книги и внесённая оплата. Если сумма совпадает со стоимость, то печатается "спасибо". Если оплата меньше стоимости, то печатается "добавьте денег". Если оплата больше стоимости, то печатается "возьмите сдачу" и сумма сдачи.
Если сможете то лучше с формулой ;)

Vadim199797 09 февр. 2015 г., 4:55:04 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Галери
09 февр. 2015 г., 6:13:47 (9 лет назад)

program First;
uses Crt;
var Price,   
     Money: integer;    

BEGIN 
       write('Введите стоимость книги ');    ReadLn(Price); 
       write('Введите количество денег ');  ReadLn(Money);   

       if Price = Money  then write ('Спасибо'); 
       if Money < Price  then write ('Добавьте денег'); 
       if Price < Money  then write ('Возьмите сдачу: ',Money-Price);  

END.

+ 0 -
Angel332
09 февр. 2015 г., 8:35:23 (9 лет назад)

program zadacha;

var stoimost,oplata: integer;  
begin 
writeln('Введите стоимость книги: '); 
readln(stoimost); 
writeln('Введите внесенную оплату: '); 
readln(oplata); 
if stoimost=oplata then writeln('Спасибо')  else 
if stoimost>oplata then writeln('Добавьте денег')  else 
if stoimost<oplata then writeln('Возьмите сдачу: ',oplata-stoimost);
end.

Ответить

Читайте также

ПАСКАЛЬ,ПОМОГИТЕ ПОЖАЛУЙСТА

Даны натуральное число n и вещественные числа a1, a2, ..., an. Определить среднее арифметическое вещественных чисел...

ПАСКАЛЬ,ПОМОГИТЕ ПОЖАЛУЙСТА

Люди Люди Люди если вы читаете это сообщение значит вы просто обязаны помочь! пожалуйста если у вас есть паскаль помогите пожалуйста решить первое и

второе задание ну или хотя бы только первое .Это вопрос жизни и смерти помогите пожалуйста P.S задание во вложениях.заранее спасибо и знайте если вы поможете значит вы самый добрый и отзывчивый человечек!)

помогите пожалуйста с информатикой вот такие задачки:

Линейные программы.
Напишите программу на ШАЯ. Вычислите площадь боковой поверхности куба. S=4a(в квадрате)
Условный оператор (ветвление)
Нарисуйте блох-схему. Найдите решение уравнения ax+b=0 если оно отсутствует.
Циклы
Напишите программу на Паскале. Вводится последовательность из N целых чисел. Сколько отрицательных чисел и сумма положительных чисел?
Одномерные массивы
Напишите программу на паскале. В одномерном массиве вычислите сумму положительных элементов.
Двумерные массивы
Напишите программу на паскале. Дан квадратный целочисленный массив. Уменьшить в два раза все его элементы.

Если что извините, надеюсь не много прошу.

Помогите!!!!очень нужно))паскаль. паскаль. 1)известны оценки по информатике каждого из 20 учеников класса. В начале списка перечислены все пятерки,

затем все остальные оценки. Сколько учеников имеют по информатике оценку пять?Условный оператор не использовать. 2)Составить программу, которая находит минимальное число большее 200, которое нацело делится на 17. Использовать цикл с предусловием While.всю программу напишите, пожалуйста)))

Помогите пожалуйста ! срочно надо!!!...в заданной последовательности целых чисел определите сумму элементов кратных 10! пример задачки вот именно под

типо по такой же системе которую щас напишу! program Maximum; i,n,max:integen; begin writeln ( 'введи элементы массива для поиска максимума'); for i:=1 to 10 do begin write ('a [', i ,']=');readln (a [ i ] ) ;end; max:=a[1]; for i = 2 to 10 do if a [ i ] > max then begin max:=a [ i ] ; n:= i ; end; writeln ('найти наибольший элемент ',max ,' под номером ', n); вот наподобие этого примера нужно построить мою задачу! в заданной последовательности целых чисел определите сумму элементов кратных 10. Помогите пожалуйста!!!



Вы находитесь на странице вопроса "Помогите пожалуйста!!!!!! (Турбо паскаль, Условный оператор)", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.