Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Какое наименьшее число почтовых марок стоимостью 10.4 и 1 руб. надо наклеить на бандероль,вес которой М грамм? Плата за посылку вычисляется следующим

10-11 класс

образом: за бандероль весом до 50 г взимается 10 руб., за каждые следующие полные или неполные 50 г - еще по 5 руб.

Vdovenko2 22 июля 2015 г., 10:23:31 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
про100марта
22 июля 2015 г., 12:33:27 (8 лет назад)

program while;

var m,s,d,ch,od:integer;

begin

writeln ('Vvedit m');

readln (m);

 if (m<50) and (m>0) then begin

 m:=m-50;  s:=10; 

while m>0 do begin

m:=m-50;

s:=s+5; 

end;

d:=s div 10; s:=s-d*10;

ch:=s div 4; s:=s-ch*4;

od:=s;

end; 

writeln ('10-',d,' 4-',ch,' 1-',od); 

readln

end. {делал без проверки в паскале} 

 

Ответить

Другие вопросы из категории

Какова траектория исполнителя Муравей после выполнения последовательности

команд: вперед (1см), направо (90о), вперед (1 см), направо
(90о), вперед (1см), направо (90о), вперед (1 см), направо
(90о)?



Определите значение переменной a после
выполнения фрагмента алгоритма:

Примечание: знаком := обозначена
операция присваивания.

Придумать слово из 9 букв
Ребят, объясните как сделать гиперссылку в презентации на другой слайд. Поясняю есть презентация, в ней 5 слайдов, первый слайд-это содержание, и мне нужно

сделать гиперссылку на другие 4 слайда из этого содержания. Помогите пожалуйста.

Читайте также

Ребят помогите программу дописать по vba: в общем нужно сделать матрицу с рандомными числами, найти наименьшее число в ней, и сделать другую матрицу на

порядок меньше, с вычеркнутым столбцом и строкой на пересечении которых находится наименьшее число из первой матрицы. Я нашел наименьшее число, а как дольше делать понять не могу.
Вот начало самой программы:
Sub laba9()
Dim N As Integer, a() As Integer, i As Byte, j As Byte, min As Integer, l1 As Integer, l2 As Integer
N = Val(InputBox("Введите размерность массива"))
ReDim a(N, N)
Sheets("Лист1").Select
Sheets("Лист1").Range("A1:AAA100").Clear
For i = 1 To N
For j = 1 To N
a(i, j) = Rnd * 100
Cells(i, j) = a(i, j)
Next j
Next i
min = a(1, 1)
l1 = 1
l2 = 2
For i = 1 To N
For j = 1 To N
If a(i, j) < min Then
min = a(i, j)
l1 = i
l2 = j
End If
Next j
Next i
End sub

Здравствуйте! 1) Подскажите пожалуйста, как перевести 973,375(10) в двоичную систему? Или можете расписать как переводить числа с запятой в двоич

ную?

2) сложить, 1011101001,1 + 1110111,01, или скажите как складывать числа с запятой, не понимаю, куда дописывать недостающие нули после запятой

1)Загадано число от 1 до 100.Загадавший на все вопросы отвечает только "да" или "нет".Какое наименьшее число вопросов нужно задать, чтобы

гарантированно угадать число? 2)В велокроссе участвуют 119 спорстменов.Специальное устройство регистрирует прохождение каждым из участников промежуточного финиша, записывая его номер с использованием минимально возможного количества бит, одинакового для каждого спортсмена.Каков информационный объем в битах сообщения, записанного устройством, после того как промежуточный финиш прошли 70 велосипедистов? Помогите пожалуйста, нужно решение как можно скорее!

Теплоход расчитан на a пассажиров и b членов комманды.Каждая спасательная шлюпка может вместить c человек . Какое наименьшее число шлюпок должно быть на

теплоходе чтобы в случае необходимости в них можно было разместить всех пассажиров и всех членов комманды (a=1000,b=30,c 50



Вы находитесь на странице вопроса "Какое наименьшее число почтовых марок стоимостью 10.4 и 1 руб. надо наклеить на бандероль,вес которой М грамм? Плата за посылку вычисляется следующим", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.