Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

привет всем)помогите пож-та с задачей. Найти и распечатать строку заданной целочисленной матрицы размером 10х10, в которой длина максимальной серии

10-11 класс

минимальна. (Серия-последовательность одинаковых элементов. Длина серии-количество одинаковых элементов) .(паскаль) очень очень нужно))) заранее спасибо))

Missyou8 24 сент. 2014 г., 2:11:50 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Miniga
24 сент. 2014 г., 3:17:42 (9 лет назад)

var 

   i, j, minlen, ind, count, countrow: ineteger;

   A:array[10, 10] of integer;

   

 

begin

   for i:=1 to 10 do

      for j:=1 to 10 do

         readln(A[i,j]);

   ind:=1;

   minlen:=11;

   for i:=1 to 10 do

   begin

      count:=1;

      countrow:=1;

      for j:=2 to 10 do

      begin

            if (A[i,j]=A[i,j-1]) then

               inc(count)

            else

            begin

               if (count>countrow) then 

                  countrow:=count;

               count:=1;

            end;

      end;

      if (countrow<minlen) then

      begin

         minlen:=countrow;

         ind:=i;

      end;

   end;

   for j:=1 to 10 do

      writeln(A[ind,j])

end.

Ответить

Другие вопросы из категории

Программа Exel

Какую функцию можно использовать в пункте 4?

В ответ запишите одно слово.

Каким термином называется концептуальная структура персонального
компьютера, от которой зависит каким образом, будет проводиться обработка
информации, то есть ее преобразование в данные, а также принципы взаимодействия
технических средств и программного обеспечения? Это понятие в широком смысле
определяется как искусство проектирования различных сооружений.

Всем привет! Помогите пожалуйста по информатике. Задача: ввести целое число и найти сумму его цифр. Пример: введите целое число:1234. Сумма цифр числа 1

234 равна 10. Задача: сумма цифр ввести целое число и определить верно ли, что в его записи есть 2 одинаковые цифры. Пример: введите целое число 1234 нет введите целое число 1224 да

Читайте также

СРОЧНО!Пишу прогу с процедурами, которая считает количество "особых "элементов матрицы, но в конце проги не работает writeln, в чём может быть проблема?

Вот задача.
Заданная целочисленная матрица размером NXM. Определить k-количество "особых" элементов матрицы, считая элемент "особым", если в его строке слева от него находятся элементы, меньшие его, а справа - большие.
Вот мой код.И если уж у меня все плохо,то предложите свой код программы.
program samost;
const n=5;
m=5;
type tmatr = array[1..n, 1..m] of integer;
var a:tmatr;
i,j,k:integer;
procedure PrintMatrix(var g:tmatr);
begin
var i,j,k:integer;
for i:=1 to n do
begin
for j:=1 to n do
write(g[i,j]:4);
writeln
end;
end;
procedure MakeMatrix;
begin
var i,j,k:integer;
randomize;
for i:=1 to n do
for j:=1 to n do
begin
a[i,j]:=random(10)-5;
end;
end;
begin
MakeMatrix;
writeln('matrica A: ');
PrintMatrix(a);

k:=0;
for i:=1 to n do
for j:=1 to m do
begin
if (a[i,j]<a[i+1,j])and(a[i,j]>a[i-1,j]) then inc(k)
end;
writeln('kolichestvo elementov = ',k);
end.

По горизонтали: 1. Минимальный элементом электронной таблицы. 2. Объект электронной таблицы, предназначенный для

представления данных в графическом виде.

4. Специальное средство для создания формулы.

5. С этого знака начинается формула.

6. Группа смежных ячеек, образующая прямоугольную область.

8. Область, обозначенная целыми числами.

По вертикали:

3. Область, обозначенная буквами латинского алфавита.

7. Операция, используемая для автоматического заполнения числовыми и текстовыми данными.

P.S срочно нужно помогите пож-та :(

Добрый день. Помогите пожалуйста решить две задачи... №1 Дан массив из 25 элементов,найти сумму 4-х наибольших и 4-х наименьших э

лементов. Результат распечатать в виде:

Сумма наибольших=

Сумма наименьших=

№2

Даны два массива по 30 элементов. Найти среднее арифмитическое для элементов 1-го массива,номера которых больше номера минимального элемента 2-го массива

Заранее спасибо



Вы находитесь на странице вопроса "привет всем)помогите пож-та с задачей. Найти и распечатать строку заданной целочисленной матрицы размером 10х10, в которой длина максимальной серии", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.