Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

даны 2 числа. отрицательные числа уменьшить на 1.

10-11 класс

программу для Паскаля, пожалуйста, напишите

12345Катя123 03 мая 2014 г., 19:04:29 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Fanie
03 мая 2014 г., 21:22:02 (10 лет назад)

program 1;
var x,y:integer;
begin
write('Введете 2 числа');
readln(x,y);
if x<0 then writeln(y-1) ;
if y<0 then writeln(x-1) else write('Таких чисел нет');
readln;
end.

Ответить

Другие вопросы из категории

Помогите пожалуйста в среде паскаль решить такую задачу:

определить сколько цифр в н- значном числе!!!! (паскаль)

как пишется arctg в Excel
Назовите исполнителей следующих видов работы:

Уборка мусора во дворе;
Обучение детей в школе;
Вождение автомобиля;
Ответ у доски;
Приготовление пищи
Печать документа на принтере

на железнодорожном вокзале 8 путей отправления поездов.вам сообщили,что ваш поезд прибывает на 4 путь.сколько информации вы получили?

В коробке лежат 64 цветных карандаша.Сообщение о том,что достали белый карандаш,несет 4бита.Сколько белых карандашей было в коробке?

Читайте также

Напишите прог-у на паскале... ПЛИИИИИИИИИИЗ 1)даны действительные числа a1, b1, c1, a2, b2, c2. Составьте программу, которая находит координаты точки

пересечения прямых, описываемых уравнениями a1x+b1x=c1 и a2x+b2x=c2. Если прямые пересекаются или не существуют-выдать соответствующее сообщение. 2) даны действительные числа a1, b1, a2, b2. Составьте программу, которая определяет, какая из точек A(a1;b1) или B(a2;b2) лежит на прямой у=2х+1. Если такой точки нет-вывести соответсвующее сообщение.

Помогите пожалуйста решить 1) дано натуральное число. Определить номер цифры 3 в нем считая от конца числа. Если такой цифры нет то ответ

0,если их несколько то номер крайней правой.

2) Дано натуральное число. Определить сумму m его последних цифр

3)Дано натуральное число. определить его максимальную цифру.

4) дано предложение. заменить в нем все вхождения под строку str1 на подстроку str2

5) последовательность чисел Фибоначчи образуется так: первый и второй член последовательности равен 1, каждый следующий равен сумме двух предыдущих(1,1,2,3,5,,8,12..) Дано натуральное число n>=3 : а) найти k-й член последовательности б)получить первые n членов последовательности в)для заданного n определить верно ли,что сумма первых n членов есть четное число

1)Проверка условия и ветвление в алгоритме.Напишите программу которая анализирует введённое с клавиатуры число и выдает на экран:

а)удвоенное значение числа,если число положительное; б)абсолютное значение числа,если число отрицательное.
2)Напишите программу которая анализирует введенное с клавиатуры число на четность и сообщает о результате.

1.Дано натуральное число:

a) найти произведение цифр числа б) верно ли, что в данном числе нет данной цифры А (цифру А вводить с клавиатуры)
2. Найти все трехзначные числа, которые при увеличении на 1 делятся на 2, при увеличении на 2 делятся на 3, при увеличении на 3 делятся на 4, а при увеличении на 4 делятся на 5.
3.Из данного натурального числа удалить все цифры А (а вводятся с клавиатуры).

Написать программы в паскале и желательно блок-схему, но можно и без нее.
Помогите пожалуйста)



Вы находитесь на странице вопроса "даны 2 числа. отрицательные числа уменьшить на 1.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.