Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Петя Васечкин хочет выяснить, делится ли на 7 натуральное число, состоящее не более чем из 60 цифр. Требуется написать программу, которая

5-9 класс

выполняетжелание Пети и находит остаток от деления введённого числа на 7.
Примеры:
Исходное число 14 Остаток 0
Исходное число 101 Остаток 3

Denis119 21 окт. 2014 г., 2:50:27 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nikiti4123
21 окт. 2014 г., 4:09:12 (9 лет назад)

var
 n:integer;

begin
 readln(n);
 writeln('Исходное число ',n,' Остаток ',n mod 7);
end.

+ 0 -
Чарахранитель
21 окт. 2014 г., 6:03:25 (9 лет назад)

Program zz;
var c,a:integer;
begin
readln(a);
c:=a mod 7;
writeln(c);
end.

Ответить

Другие вопросы из категории

"сколько лет бабушке?"Компьютер загадывает целое число от 1 до 100. Пользователь вводит с клавиатуры некоторое число и получает один из ответов:"Мое

чило меньше","Мое число больше","Вы угадали".процесс повторяется до тех пор пока не будет угадано число.

помогите на паскале сделать

Помогите решить задание номер 7 конспект

Заранее СПС

1. На двухцветном светофоре горит красный цвет. Какой объем информации несет сообщение о том, что загорится зеленый?

2. Необходимо отгадать слово, состоящее из 4 букв и записанное с помощью алфавита из 32 букв. Каждая буква угадывается по отдельности. За один ход можно получить ответ "да" или "Нет". За сколько ходов можно отгадать слово при оптимальной стратегии игры?
3. Книга состоит из 64 страниц. На каждой странице 256 символов. Какой объем информации в килобайтах содержится в книге, если используемый алфавит состоит из 32 символов?
4.Сообщение на языке племени Мульти содержит 128 символов, занимающих 1/16 часть килобайта. Сколько символов содержит алфавит племени Мульти?

Читайте также

Петя Васечкин хочет выяснить, делится ли на 7 натуральное число, состоящее не более чем

из 60 цифр.
Требуется написать программу, которая выполняет желание Пети и находит остаток от
деления введенного числа на 7

На паскале написать программу которая в последовательность чисел( натуральных), определяет сумму всех чисел кратных 4 и оканчивающихся на 6. Программа

получает на вход нат числа, признаком окончания ввода явл число 0.
Могу решить и сам, только нельзя на компе проверить. Так что надеюсь на вас.

Помогите построить блок схему к задаче

После очередного этапа чемпионата мира по кольцевым автогонкам на автомобилях с открытыми колесами Формула-А гонщики собрались вместе в кафе, чтобы обсудить полученные результаты. Они вспомнили, что в молодости соревновались не на больших болидах, а на картах – спортивных автомобилях меньших размеров.
Друзья решили выяснить победителя в одной из гонок на картах. Победителем гонки являлся тот гонщик, у которого суммарное время прохождения всех кругов трассы было минимальным.
Поскольку окончательные результаты не сохранились, то каждый из n участников той гонки вспомнил и выписал результаты прохождения каждого из m кругов трассы. К сожалению, гонщикам было сложно вычислить победителя той гонки. В связи с этим они попросили сделать это вас.
Требуется написать программу, которая вычислит победителя гонки на картах, о которой говорили гонщики.
Формат входных данных
Первая строка входных данных содержит два целых числа n и m (1 ≤ n, m ≤ 100). Последующие 2∙n строк описывают прохождение трассы каждым из участников. Описание прохождения трассы участником состоит из двух строк. Первая строка содержит имя участника с использованием только латинских букв (строчных и заглавных). Имена всех участников различны, строчные и заглавные буквы в именах различаются.
Вторая строка содержит m положительных целых чисел, где каждое число – это время прохождения данным участником каждого из m кругов трассы (каждое из этих чисел не превосходит 1000). Длина каждой строки не превышает 255 символов.
Формат выходных данных
В выходные данные необходимо вывести имя победителя гонки на картах. Если победителей несколько, требуется вывести имя любого из них.
Пример входных и выходных данных

Входные данные
Выходные данные
5 3
Sumaher
2 1 1
Barikelo
2 1 2
Olonso
1 2 1
Vasya
1 1 1
Fedya
1 1 1
Fedya

1)Напишите программу, которая в последовательности натуральных чисел определяет количество всех чисел, кратных 3 и оканчивающихся на 4. Программа получает

на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность).

2)Найти среднее арифметическое всех целых чисел от a до 200 (значения a и b вводятся с клавиатуры; a>=200);



Вы находитесь на странице вопроса "Петя Васечкин хочет выяснить, делится ли на 7 натуральное число, состоящее не более чем из 60 цифр. Требуется написать программу, которая", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.