Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Задать с клавиатуры натуральное число N, при вводе N=0 – выход из программы. Найти среднее арифметическое тех, которые кратны 5. На экран выдать в виде

10-11 класс

(5+10+15+20)/4=12,5 при N=24.

Ialkem 14 февр. 2015 г., 14:06:37 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vikasndina
14 февр. 2015 г., 16:16:25 (9 лет назад)

Program hollywood;
uses crt;
var
  n,five,sum,i: integer;
  st:string;
begin
  writeln('*** alphaues is thinking... ***');
  writeln('***          OK             ***');
  five:=0;
  sum:=0;
  st:='(';
  writeln('Введите ненулевое число');
  writeln('(или введите 0 для конца последовательности) ');
    write('Ввод:');  
    readln (n);
    st:='(';
    if n<>0 then
      begin
        for i:=1 to n do
          if i mod 5 = 0 then
            begin
              st:=st+IntToStr(i)+'+';
              five:=five+1;
              sum:=sum+i;
            end;
      end;
  delete(st, length(st),1);
  writeln(st,')/',five,' = ',sum/five);
end.

Ответить

Другие вопросы из категории

В классе 7 учеников, известны результаты сдачи экзаменов по двум предметам. Составьте программу вычисления количества учащихся, сдавщих оба экзамена на

отлично. Вывести на экран исходную матрицу-ведомость, результаты подсчета и средний балл по каждому предмету. ПАСКАЛЬ

На вопрос о погоде на завтра синоптик ответил:

1). Если будет мороз, то пойдет снег и будет пасмурно.
2). Если не будет мороза и пойдет снег, то будет пасмурно.
3). Пойдет снег, если будет пасмурно.
4). Не верно, что если не будет мороза, то будет пасмурно.
Какая будет погода завтра?

Читайте также

Требовалось написать программу,при выполнении которой с клавиатуры вводится натуральное число,не превосходящее 10^8, и выводится его первая цифра.Ученик

написал такую программу:
var n:longint;
begin
read(n);
while n>10 do
begin
n:=n mod 10
end;
write(n);
end.


1)Напишите,что выведет эта программа при вводе числа 1984.
2)Приведите пример числа,при вводе которого программа выдаст верный ответ.
3)Найдите в программе все ошибки.

1.Дано натуральное число:

a) найти произведение цифр числа б) верно ли, что в данном числе нет данной цифры А (цифру А вводить с клавиатуры)
2. Найти все трехзначные числа, которые при увеличении на 1 делятся на 2, при увеличении на 2 делятся на 3, при увеличении на 3 делятся на 4, а при увеличении на 4 делятся на 5.
3.Из данного натурального числа удалить все цифры А (а вводятся с клавиатуры).

Написать программы в паскале и желательно блок-схему, но можно и без нее.
Помогите пожалуйста)

1.пользователь вводит натуральное число. Определить среднее арифметическое цифр этого числа.

2.пользователь вводит натуральное число N. Найти сумму всех натуральных чисел от 1 до N.

Два натуральных числа называются "дружественными", если каждое из них равно сумме всех делителей другого, за исключением его самого (таковы, например,

числа 220 и 284). Напечатать все пары "дружественных" чисел, не превосходящих заданного натурального числа. (Определить функцию, вычисляющую сумму делителей числа.)сделать в C# (си шарп)Помогите пожалуйста)



Вы находитесь на странице вопроса "Задать с клавиатуры натуральное число N, при вводе N=0 – выход из программы. Найти среднее арифметическое тех, которые кратны 5. На экран выдать в виде", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.