Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Составьте программу, определяющую остаток от деления числа А на число В. Составьте программу, заменяющую большее из двух данных чисел модулем суммы, а

10-11 класс

меньшее – модулем полуразности этих чисел.(PASCAL)

Guzichka 17 марта 2017 г., 5:37:21 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Kolobovnikoval
17 марта 2017 г., 7:08:56 (7 лет назад)

1. program ostatok;

uses crt;

var a,b,ost:real;

begin

write('a= ');

readln(a);

write('b= );

readln(b);

ost:=a mod b;

write('ostatok ot delenia A na B raven ',ost);

readln;

end.

 

2. program modul;

uses crt;

var a,b,c,d: real;

begin

write('a= ');

readln(a);

write('b= );

readln(b);

c:=a-b;

if c>0 then

begin

a:=abs(a+b);

b:=abs((a-b)/2);

write('a= ',a,'b= ',b);

end

else

b:=abs(a+b);

a:=abs((b-a)/2);

write('a= ',a,'b= ',b);

end;

readln;

end.

Ответить

Другие вопросы из категории

Дано целое число. Верно ли, что оно кратно 7 и содержит 3цифры? составьте программу и проверьте ее для указанных чисел сравнив результат работы программы

с правильном результатом..
число правильный ответ
21 неверно
121 неверно
777 верно
-777 верно
ТОЛЬКО ПРОГРАММУ НАПИСАТЬ!

Читайте также

Заданы два натуральных числа N и K. Вычислить остаток от деления первого числа на второе. Входные данные: Входной поток содержит два

целых числа N и K (1 <= N <= 10^100, 1 <= K <= 10^9) записанные в двух отдельных строках.

Выходные данные:

В выходной поток выведите остаток от деления N на K.

Пример входного файла (input.txt): 239 16 Пример выходного файла (output.txt): 15

помогите составить программу!пожалуйста!!!!ооочень надо

ракета запускается с земли со скоростью V(км час) в направлении движения земли по орбите вокруг солнца. составить программу,определяющую результат запуска ракета в зависимости от скорости V.
Известно,что при V16,4 ракета покинет солнечную систему.

1. Составьте блок-схему и программу вычисления значения функции:

2. Составьте программу, определяющую, является ли данное число делителем числа 3.
3*. Составьте программу, заменяющую из двух данных чисел меньшее число суммой, а большее – произведением этих чисел.

Помогите пожалуйста ))СоставитьПомогите пожалуйста ))Составить программу по которой проверяют является ли элемент массива четным числом.Для записи

"делятся на"использовать стандартную функцию MOD,которая определяет остаток отделение числа А на число В.Примечание таблица R целочисленная.Построение блок-схемы,алгоритм и бейсики.Заранее большое спасибо))



Вы находитесь на странице вопроса "Составьте программу, определяющую остаток от деления числа А на число В. Составьте программу, заменяющую большее из двух данных чисел модулем суммы, а", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.