Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Заданы два натуральных числа N и K. Вычислить остаток от деления первого числа на второе. Входные данные: Входной поток содержит два

10-11 класс

целых числа N и K (1 <= N <= 10^100, 1 <= K <= 10^9) записанные в двух отдельных строках.

Выходные данные:

В выходной поток выведите остаток от деления N на K.

Пример входного файла (input.txt): 239 16 Пример выходного файла (output.txt): 15

Liaki 06 окт. 2014 г., 18:04:31 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Настя1402
06 окт. 2014 г., 18:38:15 (9 лет назад)

Program Task;
Var t: Text;
    N, K, M: LongInt;
Begin
    Assign(t, 'd:\input.txt');
    Reset(t);
    While Not EOF(t) Do
    Begin
    Read(t, N);
    Read(t, K);
    End;
    If (N < 1) Or (N > Exp(100 * Ln(10))) Or (K < 1) Or (K > Exp(9 * Ln(10))) Then
    WriteLn('Input error!')
    Else
    Begin
        M := N Mod K;
        Assign(t, 'd:\output.txt');
        Rewrite(t);
        Write(t, M);
        Close(t);
        Write('Done.');
    End;
    ReadLn;
End.

Ответить

Другие вопросы из категории

Устройство, предназначенное для согласования кабеля и предотвращающее появление отраженного сигнала, подсоединяемое на концах шины и к незанятым разъемам

пассивного разветвителя.


1) терминатор

2) активатор

3) концентратор

4) адаптер

5) коннектор

В книге 100 страниц на каждой странице случайное число строк от 35 до 45. на каждой строке буква А встречается случайное число раз от 2 до 5. сколько раз

буква А встречается в книге. Написать программу в Паскале. Помогите пожалуйста

ПОМОГИТЕ ПОЖАЛУЙСТА!!!! Составьте программу для решения следующей задачи. Введите с клавиатуры два числа: N и M. Если оба числа больше 100, то замените

каждое из них меньшим и выведите результаты на экран. Если первое число положительное, а второе отрицательное, то уменьшите их в два раза и выведите результаты. Иначе, найдите и выведите среднее арифметическое этих чисел.

Читайте также

Два натуральных числа называются "дружественными", если каждое из них равно сумме всех делителей другого, за исключением его самого (таковы, например,

числа 220 и 284). Напечатать все пары "дружественных" чисел, не превосходящих заданного натурального числа. (Определить функцию, вычисляющую сумму делителей числа.)сделать в C# (си шарп)Помогите пожалуйста)

Известна математическая задача: "Существуют ли два последовательных натуральных числа, сумма цифр каждого из которых делится на 7?" Напишите программу,

которая отвечает на вопрос: "Существуют ли два последовательных числа, не превосходящих N, сумма цифр каждого из которых делится на k?"
Входные данные. Два числа N (1 \leq N \leq 10000000000), k (1 \leq k \leq 100)
Выходные данные. Программа выводит два таких числа, если они существуют, "NO" - если нет.

1)По данному числу n вычислите сумму 2(1-1/3+1/5-1/7+...+(-1)n/(2n+1)). Формат входных данных: Вводится одно число n, не превосходящее 100000.

Формат выходных данных: Необходимо вывести значение выражения 2) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b,не дающие остаток c при делении на d 3) Подсчитайте, сколько среди данных N чисел нулей, четных чисел, нечетных чисел. Вводится число N, а затем N чисел. Необходимо вывести сначала число нулей, затем число четных и нечетных чисел 4) электронное устройство, выдает каждую секунду очередное число последовательности 1, 2, 2, 3, 3, 3, 4, 4, 4, 4, 5... Ввиду дороговизны электронных комплектующих вам поручено разработать эмулятор для этого устройства. Формат входных данных: Дано количество секунд (от 1 до 1000000), которые работает генератор после включения. Формат выходных данных: Результат работы генератора(пример 2 1 2 5 1 2 2 3 3) 5)Вклад в банке составляет x рублей. Ежегодно он увеличивается на p процентов, после чего дробная часть копеек отбрасывается. Каждый год сумма вклада становится больше. Определите, через сколько лет вклад составит не менее y рублей.Программа получает на вход три натуральных числа: x, p, y и должна вывести одно целое число 6)Исполнитель “Раздвоитель” преобразует натуральные числа. У него есть две команды: “Вычесть 1” и “Разделить на 2”, первая команда уменьшает число на 1, вторая команда уменьшает число в два раза, если оно чётное, иначе происходит ошибка.Дано два натуральных числа A и B (A>B). Напишите алгоритм для Развоителя, который преобразует число A в число B и при этом содержит минимальное число команд. Команды алгоритма нужно выводить по одной в строке, первая команда обозначается, как -1, вторая команда как :2.

Натуральное число называется числом Армстронга, если сумма цифр числа, возведенных в К- ю степень( где К- количество цифр в числе) равна самому числу.

Например, 153=1³ + 5³ + 3³.
Входная строка содержит два натуральных числа- значения а и б.
Входные данные
Входная строка содержит два натуральных числа - значения а и б, разделенных пробелами. Гарантируется, что а≥б.
Выходные данные
Программа должна вывести в одну строчку все числа Армстронга на отрезке а, б, разделив их пробелами. если таких чисел нет, программа должна вывести -1.

Дано два натуральных числа N и M.

Написать программу для определения
наименьшего из чисел, составленных из цифр данных чисел. Незначащих
нулей в найденном числе быть не должно.

Формат входных данных:



Вы находитесь на странице вопроса "Заданы два натуральных числа N и K. Вычислить остаток от деления первого числа на второе. Входные данные: Входной поток содержит два", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.