Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Числа Вам даны число N и цифра D.

5-9 класс

Выведите все

вероника21022002 22 марта 2017 г., 5:02:36 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
6лук
22 марта 2017 г., 7:33:17 (7 лет назад)

uses crt;
var n,d,z,x,c,k,a,b:integer;
begin
     write('N:'); readln(n);
     write('D:'); readln(d);
     a:=round(power(10,n-1));
     b:=round(power(10,n)-1);
     for x:=a to b do
     begin
          z:=x;
          k:=0;
          while z>0 do
          begin
               c:=z mod 10;
               if c=d then inc(k);
               z:=z div 10;
          end;
          if  k=0 then writeln(x);
     end;
end.

+ 0 -
20146
22 марта 2017 г., 10:33:15 (7 лет назад)

Роки молодец!

Ответить

Другие вопросы из категории

как сделать в 7 ходов
За один ход с числом делается операция вида: если число не делится на 3,то вычетаем 1 а если делится , то делим на 3.Так из числа 39 единица получается за

5 таких ходов(имеется в виду цепочка, 39-13-12-4-3-1)
Программа должна:
-Запросить число ходов k(натуральное число,0<=k<=37)
-Найти и вывести на экранНаименьшее натуральное число, которое превращается в единицу за k таких ходов.
Язык программы Pascal АВС.

Читайте также

Помогите пожалуйста Решить 2 задачи на языке Паскаль! 1) По данному числу N распечатайте все целые степени двойки, не

превосходящие N, в порядке возрастания.

Операцией возведения в степень пользоваться нельзя!

2)

В первый день спортсмен пробежал x километров, а затем он каждый день увеличивал пробег на 10% от предыдущего значения. По данному числу y определите номер дня, на который пробег спортсмена составит не менее y километров.

Программа получает на вход действительные числа x и y и должна вывести одно натуральное число.

Помогите пожалуйстааааа, хотя бы не все но некоторые помогите сделать прошууу:) 1. Перевести данное число из десятичной системы счисления в

двоичную, восьмеричную и шестнадцатеричную системы счисления. а) 113(10); б) 875(10); в) 535,1875(10); г) 649,25(10); д) 6,52(10). 2. Перевести данное число в десятичную систему счисления. а) 11101000(2); б) 1010001111(2); в) 1101101000,01(2); г) 1000000101,01011(2); д) 1600,14(8); е) 1E9,4(16).

1. Перевести данное число из десятичной СС в двоичную СС, восьмеричную и шестнадцатеричную СС. а) 500(10); б) 675(10); в) 810,25(10); г)

1017,25(10); д) 123,72(10)

2. Перевести данное число в десятичную СС.

а) 1101010001(2); б) 100011100(2); в) 1101110001,011011(2); г) 110011000,111001(2); д) 1347,17(8); е) 155,6C(16)

1. Перевести данное число из десятичной системы счисления в двоичную, восьмеричную и шестнадцатеричную системы счисления А) 273(10) Б) 156,25(10)

2. Перевести данное число в десятичную систему счисления. а) 1100000000(2) б) 1011001101,00011(2) в)1017,2(8) г) 111,В(16)

Некоторый алгоритм из одного числа получает новое число следующим образом. Исходное число записывается дважды(друг за другом), а в конец получившегося

числа дописывается столько нулей, сколько четных цифр в исходном числе. Получившееся число является результатом работы алгоритма. Например, исходное число было 325, то результатом работы алгоритма было число 3253250. Дано число 144. Сколько нулей будет содержаться в итоговом числе, если к исходному числу применить описанный алгоритм дважды(т.е. применить алгоритм к данному числу, а затем к данному результату вновь применить алгоритм. Необходимо написать подробное решение и объяснить задачу на пальцах.



Вы находитесь на странице вопроса "Числа Вам даны число N и цифра D.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.