Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Помогите пожалуйста! 8класс! Ввести натуральное число и определить, какие цифры встречаются несколько раз. Решить с помощью цикла с условием! Заранее

5-9 класс

спасибо!

Julia8987 10 июля 2016 г., 3:35:05 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Mari14
10 июля 2016 г., 5:05:47 (7 лет назад)

program asd;
uses crt;
var s,s1:string;
i,j,k: integer;
b1,b2:boolean;
begin
writeln('Vvedite naturalnoe chislo:');
readln(s);
for i:=1 to length(s) do
begin
b1:=false;
b2:=true;
for j:=1 to length(s) do
begin
if i<>j then
if s[i]=s[j] then
begin
b1:=true;
for k:=1 to length(s1) do
if s[i]=s1[k] then b2:=false;
end;
end;
if b1 and b2 then s1:=s1+s[i]+' ';
end;
if length(s1)<>0 then
begin
writeln('Повторяются: ',s1);
end
else writeln('Ничего не повторяется');
readln;
end.

Ответить

Читайте также

Программу надо написать в PascalABC, с использованием команд repeat и until. Ввести натуральное число и определить, какие цифры встречаются несколько раз

(с защитой от неверного ввода) или Ввести натуральное число и определить, верно ли, что сумма его цифр равна 10 (с защитой от неверного ввода).

Помогите, пожалуйста, решить :)

Паскаль
с while
Ввести натуральное число и определить, какие цифры встречаются несколько раз (с защитой от неверного ввода).

Ввести натуральное

число и определить, какие цифры встречаются несколько раз.

Пример:

Напишите программу в Паскаль для решения задачи:

Ввести натуральное число и определить, верно ли, что сумма его цифр равна 10

ПАСКАЛЬ,ПОМОГИТЕ ПОЖАЛУЙСТА

Даны натуральное число n и вещественные числа a1, a2, ..., an. Определить среднее арифметическое вещественных чисел...

ПАСКАЛЬ,ПОМОГИТЕ ПОЖАЛУЙСТА



Вы находитесь на странице вопроса "Помогите пожалуйста! 8класс! Ввести натуральное число и определить, какие цифры встречаются несколько раз. Решить с помощью цикла с условием! Заранее", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.