Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

алгоритм. среди пяти чисел найти среднее арифметическое

5-9 класс

Bg1981 22 окт. 2016 г., 22:06:38 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Надежда19803009
22 окт. 2016 г., 23:13:23 (7 лет назад)

Сред. Арифметическое = Сумма всех чисел разделить на количество

 

(A1 + A2 + A3 + A4 + A5) / 5

+ 0 -
Lyailyusha16
23 окт. 2016 г., 1:55:30 (7 лет назад)

program rrr;
uses crt;
const n=9;
type massiv=array[1..n]of real;
var a:massiv;
max,sr:integer;
procedure vvod(var x:massiv);
var i:integer;
begin
writeln('wwedite massiv');
for i:=1 to n do
readln(x[i]);
end;
procedure vivod(x:massiv);
var i:integer;
begin
for i:=1 to n do
write(x[i]:6:2,' ');
end;
procedure sred_ar_i_max(x:massiv,var sr,max:real);
var sum:real; i:integer;
begin
s:=0;
for i:=1 to n do
if x[i]>0 then s:=s+x[i];
end;
sr:=s/n;
for i:=1 to n do
if (x[i]>0) and max<x[i] then max:=x[i];
end;
vvod(a);
clrscr;
vivod(a);
sred_ar_i_max(a,sr,max);
writeln('max=',max:6:2,'srednee arifmet=',sr:6:2);
readln;
end.

Ответить

Другие вопросы из категории

Помогите мне пожалуйста!! Я много проболела и тут учитель по информатике задал тест и подготовку дал 1 день! А я ничего не знаю, совершенно=(((((

1) Сообщение записано буквами из 16 символьного алфавита, содержит 145 символов. Какой объем информации оно несет?
2) Информационное сообщение объемом 2.5 Кбайта содержит 2560 символов. Сколько символов содержит алфавит, при помощи которого было записано это сообщение?
3) Для записи текста использовался 4 - символьный алфавит. Каждая страница содержит 30 строк по 70 символов в строке. Какой объем информации содержат 5 страниц текста?
4) Сообщение занимает 4 страницы по 50 строк. В каждой строке записано по 65 символов. Сколько символов а алфавите, если все сообщение содержит 8125 байтов?
5)Сообщение записано буквами из 64 символьного алфавита содержит 60 символов. Какой объем информации оно имеет?
6) Сколько Кбайт составляет сообщение, содержащее 16384 бит?
7)Информационное сообщение объемом 0.25 Кбайта содержит 1024 символа. Сколько символов содержит алфавит, при помощи которого было записано это сообщение?
8) Для записи текста использовался 256 - символьный алфавит. Каждая страница содержит 30 строк по 70 символов в строке. Какой объем информации содержат 5 страниц текста?
9) Сообщение занимает 6 страниц по 35 строк. В каждой строке записано по 50 символов. Сколько символов в алфавите, если все сообщение содержит 7875 байтов?

Читайте также

1.Дан массив целых чисел, найти среднее арифметическое всех элементов массива.

2. Дан массив целых чисел,найти количество отрицательных элементов массива.
3. Дан массив целых чисел,найти количество чётных чисел в массиве.

Напишите программу, которая в последовательности целых чисел находит среднее арифметическое чисел, кратных 9, или сообщает, что таких чисел нет.

Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не является членом последовательности). Количество чисел не превышает 100. Введённые числа по модулю не превышают 300. Программа должна вывести среднее арифметическое чисел, кратных 9, или вывести NO, если таких чисел в последовательности нет.



Вы находитесь на странице вопроса "алгоритм. среди пяти чисел найти среднее арифметическое", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.