Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

обменять значения двух переменных используя третью (буферную) переменную.

10-11 класс

Rutigr 06 июля 2014 г., 10:53:21 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
вадим19032004
06 июля 2014 г., 12:43:36 (9 лет назад)

var a,b,c:integer;

begin

read(a);

read(b);

c:=a;

a:=b

b:=c;

end.

+ 0 -
Vladislafv
06 июля 2014 г., 13:24:56 (9 лет назад)

а какой это класс???????????

Ответить

Другие вопросы из категории

Напишите программу в паскаль для решения следующей задачи: для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие

результаты. Если первое из них отрицательно, а второе вдвое больше третьего, то выведите среднее арифметическое всех четырех чисел. Если произведение этих четырех чисел больше их суммы, то выведите эти сумму и произведение. Если выполняются одновременно два перечисленных выше условия, то выведите среднее арифметическое этих чисел, их произведение и сумму. Иначе, выведите удвоенные значения этих чисел.

В чем ошибка? var x:real; fuction x1(a,b:integer):real; begin x1:=a+sqrt(b)/b+a; end; begin x:=

x1(15+8)/8+15 + x1(6+12)/12+6 + x1(7+21)/21+7;

writeln('x=', x:6:2);

end.

Общее имя: город,конкретное имя:?

Читайте также

1. Написать программу, которая выводит на экран сумму средних арифметических значений двух вещественных массивов из 10 элементов.

2. Написать прогрумму,которая выводит на экран, разность значений двух вещественных массивов из 10 элементов.

1.Напишите команды, которые выполняют следующие действия: а) вывод переменной с ;б) описать переменные а и s целого типа; в) переменной r присваивает

разность чисел p и q.
2.Что будет на экране после выполнения следующих команд: а) Writeln(9); Write(5); Writeln(3); б) Writeln(4*2); Write('5-3'); Writeln('5+1=',5+1);
3.Укажите различия циклов While и Repeat
4.Дана строка. Определить сколько пробелов в этой строке
6.Дано четырехзначное число. Вывести на экран сумму цифр этого числа
7.Найти количество цифр целого числа N
8.Напишите команды, которые выполняют следующие действия: а) ввод переменной d б) описать переменные m и n вещественного типа. в) переменной s присвоить разность чисел p и q
9.Что будет на экране после выполнения следующих команд: Writeln(5-3); Write('5+3'); Writeln('5*4=',5*4);
10.Когда нельзя применять цикл for
11.Дана строка. Определить сколько букв в этой строке
12.Дано трехзначное число. Вывести на экран все его цифры столбиком
13. Найти количество цифр целого числа N(+блок-схема)

Напишите программу, которая считывает значения двух целочисленных переменных a и b, затем меняет их значения местами (то есть в переменной a должно быть

записано то, что раньше хранилось в b, а в переменной b записано то, что раньше хранилось в a). Затем выведите значения переменных.

1.Написать

процедуру, меняющую значения двух переменных а и b местами.
2.Используя
процедуру обмена значений двух переменных, упорядочьте по возрастанию
переменные a, b, c.






Вы находитесь на странице вопроса "обменять значения двух переменных используя третью (буферную) переменную.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.