Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

В чем ошибка? var x:real; fuction x1(a,b:integer):real; begin x1:=a+sqrt(b)/b+a; end; begin x:=

10-11 класс

x1(15+8)/8+15 + x1(6+12)/12+6 + x1(7+21)/21+7;

writeln('x=', x:6:2);

end.

Кристина007 25 февр. 2014 г., 3:02:03 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nana1123
25 февр. 2014 г., 3:46:23 (10 лет назад)

В Var все переменные подставь, программа просто их не видит, т.к. они не указаны там.

+ 0 -
Мария1909
25 февр. 2014 г., 6:04:13 (10 лет назад)

 Во первых в основной прграмме x:=x1*(15+8)/8+15+x1*(7+21)/21+7;

Во вторых если упростить выражение то получиться x:=2*x1;

 

 

 

Ответить

Другие вопросы из категории

Общее имя: город,конкретное имя:?
Составьте Paskal-программу решение следующей задачи:

Задан массив A(n).Найти сумму и количество чётных отрицательных элементов этого массива

11. Вася скачивает материалы для монтажа видеоролика длительностью N секунд, с использованием протокола torrent. Особенностью этого протокола является то,

что параллельно со скачиванием разбитого на небольшие фрагменты файла происходит раздача скачанных фрагментов. Торрент клиент настроен таким образом, что максимальная скорость скачивания 15 МБайт/с, а максимальная скорость раздачи – 5 МБайт/с.

Материалы включают в себя:
Несжатые изображения кадров, размером 1920*1080 точек с глубиной цвета 16 бит из расчета 18 изображений на секунду воспроизведения.
Несжатую звуковую дорожку длительностью N секунд, включающую 48 каналов, каждый из которых оцифрован с частотой дискретизации 192000 Гц и 4096 уровнями квантования.
Никакой другой информации, кроме описанной, в скачиваемых материалах нет.
Определите N - длительность видеоролика в секундах при условии, что раздача фрагментов началась одновременно с началом скачивания, и за время скачивания материалов было роздано 8100 МБайт. Скачивание и раздача все время осуществлялась на максимальных скоростях. Примечание: 1МБайт=2^20 байт. В ответе укажите значение N.

Читайте также

в чем ошибка? сразу выделяет вторую строку и пишет ошибку declaration expected but identifier 's' found я уже весь интернет облазила, но не

понимаю, в чем суть ошибки

uses
SysUtils;
s,k,n:integer;
begin

writeln('vvedite n');
readln(n);
s:=0;
k:=1;
for i:=1 to n do
s:=i*(sqr*k);
i:=i+1;
writeln('s=',s:4:3);
{ TODO -oUser -cConsole Main : Insert code here }
end

Как в этой программе задать свой промежуток от m до n а не от 1 до n

program z;
var n,i,j,s,mx,imx:integer;
begin
repeat
write('n>0 n=');
readln(n);
until n>0;
mx:=1;
imx:=1;
for i:=1 to n do
begin
s:=0;
for j:=1 to i do
if i mod j=0 then s:=s+j;
if s>mx then
begin
mx:=s;
imx:=i
end;
end;
writeln('Максимальную сумму делителей имеет число ',imx,' сумма=',mx);
readln
end.

Если в прямоугольной матрице меньше половины столбцов содержит отрицательные элементы, то все элементы с нечетными номерами столбцов умножить на 10. В

противном случае все отрицательные элементы матрицы возвести в квадрат.

У меня получилось вот что:

program s455;
uses crt;
const
m=10;
n=12;
Var
A: array[1..m,1..n] of integer;
i, j, k, s: integer;

Begin
writeln('Enter size');
readln;
s:=0;
for j:=1 to m do
begin
k:=0;
for i:=1 to n do
end;
begin
if a<0 then begin
k:=1;
end;
if k=1 then s:=s+1;
end;
begin;
if k<0
then a[i, j]:=a[i, j*2-1]*10;
else a[i, j]:=a[i, j]*c [i, j]
end;
writeln

Не могу понять в чем ошибка

написать функцию,сравнивающую две даты.функция должна возвращать(-1) если первая дата меньше второй ,0- если первая и вторая даты одинаковы и 1

-если первая дата больше второй.паскаль.тема записи
в чем ошибка??
type date = record day: 1..31; month: 1..12; year: integer ; end;
var a: date := (day: 1; month: 4; year: 2015); b: date := (day: 1; month: 4; year: 2014); c:integer;

procedure OutDate(d: date);begin with d do writeln(day, '.', month, '.', year);end;
function Srawn(x, y: date): -1..1;beginif x.year > y.year then writeln( 1) else writeln(-1) ; if x.year = y.year then if x.month > y.month then writeln(1) else writeln(-1); if x.year = y.year then if x.month = y.month then if x.day > y.day then writeln(1) else writeln(-1); if x.year = y.year then if x.month = y.month then if x.day = y.day then writeln(0); end; begin OutDate(a); OutDate(b); c:=srawn(a,b); writeln('otwet:', c);end.

Var a:array [1..100,1..100] of real;

b:array [1..100,1..100] of real;
i,m,n,c:integer;
begin
readln(n);
readln(c);
for i:=1 to n do
for m:=1 to c do readln(a[i,m]);
for i:=1 to n do
for m:=1 to c do
b[i,m]:=a[i,m]/8;
for i:=1 to n do
for m:=1 to c do writeln(b[i,m]);
end.
можете написать обозначение каждого символа



Вы находитесь на странице вопроса "В чем ошибка? var x:real; fuction x1(a,b:integer):real; begin x1:=a+sqrt(b)/b+a; end; begin x:=", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.