Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

в чем ошибка? сразу выделяет вторую строку и пишет ошибку declaration expected but identifier 's' found я уже весь интернет облазила, но не

10-11 класс

понимаю, в чем суть ошибки

uses
SysUtils;
s,k,n:integer;
begin

writeln('vvedite n');
readln(n);
s:=0;
k:=1;
for i:=1 to n do
s:=i*(sqr*k);
i:=i+1;
writeln('s=',s:4:3);
{ TODO -oUser -cConsole Main : Insert code here }
end

Goldeneye 20 июня 2013 г., 12:50:05 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Krybak99
20 июня 2013 г., 15:30:43 (10 лет назад)

s,k,n:integer; нужно писать не в uses, а в var, т..е будет "var s,k,n:integer; "

Ответить

Другие вопросы из категории

Какой набор символов будет выведен в результате работы следующей программы? function f(x:string; a:byte):string; begin

if a<=3 then

f:=copy (x,1,a)

else

f:=f(copy(x,2,a),a-2);

end;

begin

writeln(f(`abcdefghijklm`,7));

end.

Задача 1. Поставьте знак сравнения (>, <, =) между парами строк и объ-ясните свой ответ.

'windranger'____'wind'
'ASCII'____'Ascii'
'cat'____'cat'
'винни-пух'____'Сова'
Задача 2. Запишите результат выполнения следующих стандартных процедур:
Val('23.456', x, k)
Val('-45', x, k)
Val('5.87c-5', x, k)

Помогите пожалуйста)

Найдите среднее арифметическое следующих чисел:

а) 100101102, 11001002, 1100102

б) 2268, 6416 и 6210

Читайте также

Ошибка времени выполнения: Входная строка имела неверный формат

Написал программу:

var
f1,f2:text;
d,s,z,n:longword;
a,b,t,m,x:smallint;
begin
assign(f1,'input.txt');
reset(f1);
assign(f2,'output.txt');
rewrite(f2);
readln(f1,d,a,b,s,t);
if a>b then x:=a-b else x:=b-a;
if d mod s=0 then n:=d div s else n:=d div s+1;
if x mod t=0 then m:=x div t else m:=x div t+1;
z:=n+m;
write(f2,z);
close(f1);
close(f2);
end.

Выдает ошибку: Ошибка времени выполнения: Входная строка имела неверный формат.
Где выдает ошибку: readln(f1,d,a,b,s,t);

ПОМОГИТЕ пожалуйста!!!

Помогите решить на с++ или pascale срочно

Таймер - это часы, которые умеют подавать звуковой сигнал по прошествии некоторого периода времени. Напишите программу, которая определяет, когда должен быть подан звуковой сигнал.Входные данныеВ первой строке входного файла INPUT.TXT записано текущее время в формате ЧЧ:ММ:СС (с ведущими нулями). При этом оно удовлетворяет ограничениям: ЧЧ - от 00 до 23, ММ и СС - от 00 до 60.Во второй строке записан интервал времени, который должен быть измерен. Интервал записывается в формате Ч:М:С (где Ч, М и С - от 0 до 109, без ведущих нулей). Дополнительно если Ч=0 (или Ч=0 и М=0), то они могут быть опущены. Например, 100:60 на самом деле означает 100 минут 60 секунд, что то же самое, что 101:0 или 1:41:0. А 42 обозначает 42 секунды. 100:100:100 - 100 часов, 100 минут, 100 секунд, что то же самое, что 101:41:40.

Задача на C++.

Для прямоугольной комнаты размером W x H метров нужно закупить линолеум. В магазине линолеум продают рулонами; вам известно количество квадратных метров линолеума в одном рулоне и цена рулона.

Требуется определить, хватит ли имеющейся суммы денег на покупку линолеума.

Линолеум также может быть закуплен у иностранного поставщика, поэтому требуется узнать его стоимость в иностранной валюте, курс которой по отношению к рублю известен.

Входные данные
Первая строка содержит два целых числа W и H (1 <= W, H <= 1000) — соответственно длину и ширину комнаты в метрах.

Вторая строка содержит два целых числа K и P (1 <= K, P <= 1000) — соответственно количество квадратных метров линолеума в одном рулоне и цену одного рулона в рублях.

Третья строка содержит одно целое число M (1 <= M <= 10^6) — количество имеющихся денег в рублях.

Четвёртая строка содержит одно вещественное число T (0 < T <= 10) — стоимость рубля в иностранной валюте.

Выходные данные
В первой строке выведите два целых числа — количество рулонов линолеума, которое потребуется приобрести, и общую стоимость линолеума в рублях.

Во второй строке выведите "YES" (без кавычек), если имеющихся денег хватит на покупку линолеума, иначе выведите "NO" (без кавычек).

В третьей строке выведите одно вещественное число с четырьмя знаками после запятой — общую стоимость линолеума в иностранной валюте.



Вы находитесь на странице вопроса "в чем ошибка? сразу выделяет вторую строку и пишет ошибку declaration expected but identifier 's' found я уже весь интернет облазила, но не", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.