Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Задача на C++.

10-11 класс

Для прямоугольной комнаты размером W x H метров нужно закупить линолеум. В магазине линолеум продают рулонами; вам известно количество квадратных метров линолеума в одном рулоне и цена рулона.

Требуется определить, хватит ли имеющейся суммы денег на покупку линолеума.

Линолеум также может быть закуплен у иностранного поставщика, поэтому требуется узнать его стоимость в иностранной валюте, курс которой по отношению к рублю известен.

Входные данные
Первая строка содержит два целых числа W и H (1 <= W, H <= 1000) — соответственно длину и ширину комнаты в метрах.

Вторая строка содержит два целых числа K и P (1 <= K, P <= 1000) — соответственно количество квадратных метров линолеума в одном рулоне и цену одного рулона в рублях.

Третья строка содержит одно целое число M (1 <= M <= 10^6) — количество имеющихся денег в рублях.

Четвёртая строка содержит одно вещественное число T (0 < T <= 10) — стоимость рубля в иностранной валюте.

Выходные данные
В первой строке выведите два целых числа — количество рулонов линолеума, которое потребуется приобрести, и общую стоимость линолеума в рублях.

Во второй строке выведите "YES" (без кавычек), если имеющихся денег хватит на покупку линолеума, иначе выведите "NO" (без кавычек).

В третьей строке выведите одно вещественное число с четырьмя знаками после запятой — общую стоимость линолеума в иностранной валюте.

Milka6666 16 сент. 2013 г., 21:22:30 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Alvinka00
16 сент. 2013 г., 23:10:42 (10 лет назад)

#include <iostream>
#include <iomanip>      // std::setprecision

int main()
{
  unsigned int W,H,K,P;  
  unsigned long M;
  float T;
  std::cin >> W >> H >> K >> P >> M >> T;
  unsigned int n = (W*H);
  std::cout << (n = ((n / K) + !(!(n % K)))) << "  ";
  std::cout << (n = (n*P)) << std::endl;
  std::cout << ((M-n > 0) ? "YES" : "NO") << std::endl;
  std::cout << std::setprecision(4) << (float(n) / T) << std::endl;

  return 0;
}

Ответить

Читайте также

Отдаю все баллы. У меня паника. Нужно максимум через 3 часа. Помогите решить задачи на pascal abc.

а первом фото 4 с процедурой, 8 с функцией.

На втором фото 8 с рекурсивной процедурой.

реализовать задачу на компьютере, используя операторы цикла и вложеннные операторы цикла.

задача. даны площади нескольких квадратов. найти длину диагонали самого большого из них.

Помогите решить задание (задачу) на языке паскаль. Начав тренировки, спортсмен в первый день пробежал 10 км. Каждый день он увеличивал дневную норму на

10% нормы предыдущего дня. Какой суммарный путь пробежит спортсмен за N дней? Разработать схему алгоритма для решения этой задачи.

Решить любую из двух задач. Если две - то спасибо :)

1) В одномерном массиве встречаются нули. Согнать их всех в одну сторону.(задача на пузырьковый метод)
2) После ввода одномерного массива:
-сначало идут положительные по возрастанию

-потом все нули

-потом все отрицательные чила по возрастанию

Пример:-1 5 -7 0 3 0 -2 6 8

вывод: 3 5 6 8 0 0 -7 -2 -1

Помогите, очень прошу вас.

Задачи на массив в Turbo Pascal

1) Определите ,на сколько отличается рост самого высокого и самого низкого учащегося в классе?
2) результаты переписи населения, которые хранятся в памяти компьютера. Элемент массива -год рождения жителя. Подсчитайте общее число жителей, родившихся раньше 1958 года.
3) С 8 до 20 часов температура воздуха измерялась ежечасно, и результаты измерения заносились в компьютер. Известно, что в течение этого времени температура понижалась. Напишите программу, определяющую, в котором часу была впервые отмечена отрицательная температура



Вы находитесь на странице вопроса "Задача на C++.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.