Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Как в этой программе задать свой промежуток от m до n а не от 1 до n

10-11 класс

program z;
var n,i,j,s,mx,imx:integer;
begin
repeat
write('n>0 n=');
readln(n);
until n>0;
mx:=1;
imx:=1;
for i:=1 to n do
begin
s:=0;
for j:=1 to i do
if i mod j=0 then s:=s+j;
if s>mx then
begin
mx:=s;
imx:=i
end;
end;
writeln('Максимальную сумму делителей имеет число ',imx,' сумма=',mx);
readln
end.

Ladycat99 12 февр. 2014 г., 1:03:14 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Настя193
12 февр. 2014 г., 2:53:53 (10 лет назад)

В строке for i:=1 to n do меняй 1 на m.

+ 0 -
Anutacherk
12 февр. 2014 г., 5:35:42 (10 лет назад)

Поменять счетчики в циклах 1 на m соотвественно

Ответить

Другие вопросы из категории

Дана непустая последовательность натуральных чисел, за которой следует 0. Составьте программу нахождения суммы чисел этой

последовательности.Запустите программу на выполнение...(ПО ПАСКАЛЮ..)

Читайте также

В программе используется одномерный целочисленный массив А с индексами от 0 до 10. Ниже представлен фрагмент программы в котором значения элементов

сначала задаются,а затем меняются.

Нц для i от 0 до 10

А [ i ] := i

кц

Нц для i от 0 до 4

С := A[ i ]

A[ i ] := A [10 - i ]

A [10 - i ] :=C

кц

Чему будут равны элементы массива после выполнения фрагмента программы?

1) 10 9 8 7 6 5 4 3 2 1 0

2) 0 1 2 3 4 5 6 7 8 9 10

3) 10 9 8 7 6 5 6 7 8 9 10

4) 0 1 2 3 4 5 4 3 2 1 0

Дана строка , в которой содержится осмысленное текстовое сообщение. Слова сообщения разделяются В заданном формате дд- целое число из диапазона от 1 до

31, мм - целое число из диапазона от 1 до 12, а гг - целое число из диапазона от 1 до 2020 (если какая-то часть формата нарушена, то данная подстрока в качестве даты не рассматривается.) Заменить каждую дату сообщения на дату следующего дня. Написать программу на Паскале. Сроооооооооооооочнооо. Пооожалуйста.....

10-11 класс информатика ответов нет
1)составьте программу вычисления суммы чисел в диапазоне от 45 до 115 45+....+115

2)Составьте программу которая выводит на экран числа кратные 2 и 13 в диапазоне от 2 до 150
3)Дано вещественное число А и целое число N(>0).Испульзуя один цикл вывести все целые степени числа А от 1 до N

------------------------ОПЕРАТОР WHILE

1. Пользователем вводится целое число. Вывести на экран последовательность целых чисел от единицы до этого числа.

2.Вывести на экран 10 строк, содержащие символ *, причем количество * в каждой строке должно быть равно номеру строки.
3.Пользователем вводится 2 целых числа. Вывести на экран сумму положительных четных чисел, находящихся в границах диапазона, указанного пользователем.
4. В результате работы программы формируется массив, состоящий из 10 элементов и заполненный случайными числами от 0 до 100. Вывести на экран этот же массив в порядке возрастания.
5.Вводится строка, содержащая буквы и цифры разного регистра (т.е. строчные и прописные буквы). В результате работы программы на экран выводится строка следующего вида: цифры в порядке возрастания, строчные буквы по алфавиту, прописные буквы по алфавиту.

№1. Дан массив из 30-ти элементов. Каждый элемент может принимать целочисленные значения от 0 до 100. Напишите программу, которая позволит найти сумму

двузначных элементов массива, которые не оканчиваются на 3. №2. Дан массив из 100 элементов. Каждый элемент может принимать целочисленные значения от 1 до 500. Напишите программу, которая позволит найти и вывести минимальное значение среди элементов массива, которые делят максимальное значение элементов массива без остатка.



Вы находитесь на странице вопроса "Как в этой программе задать свой промежуток от m до n а не от 1 до n", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.