Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

В ПАСКАЛЕ

10-11 класс

1. В целочисленной последовательности есть нулевые элементы. Создать массив из номеров этих элементов.
2.Дан массив действительных чисел,размерность которого N. Подсчитать сколько в нем отрицательных положительных и нулевых элементов.

Qwerty21178 19 дек. 2016 г., 20:59:32 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
жасмин007
19 дек. 2016 г., 22:25:37 (7 лет назад)

2 задача
program _2;
var a:array [1..n] of integer;
x,y,s,i:integer;
begin
for i:=1 to n do readln(a[i]);
s:=0;x:=0;y:=0;
for i:=1 to n do if a[i]=o then s:=s+1 else if a[i]>0 then x:=x+1 else if a[i]<0 then y:=y+1; writeln(s, x, y);end.

Ответить

Другие вопросы из категории

Сделайте блок схему циклического алгоритма.

Составьте программу, которая вычисляет сумму чисел от 1 до N. Значение N вводится с клавиатуры.

переведите целое десятичное число 124 в двоичную систему счисления

а) делением на 2
б) по схеме N в 10->N в 8->n в 2
в) по схеме N в 10->N в 16->n в 2

очень надо, помогите прошу Дано целое число К. Вывести строку-описание оценки, соответствующей числу К (1- "плохо" , 2-

"неудовлетворительно" , 3 - "удовлетворительно" , 4- "хорошо" , 5- "отлично". Если К не лежит в диапазоне 1-5 , вывести "ошибка".

Читайте также

Рассказать и показать на примере Паскаль: 1) Что такое absolute и для чего нужна? 2) Что такое asm и для чего нужна? 3) Что такое

constructor и destructor и для чего нужна?

4) Что такое implementation и для чего нужна?

5) Назовите модули Паскаль ( в строке Uses, например crt) и какие возможности этот модуль дает?

6) Что за тип переменной: указательный (Pointer)

7) И на последок: что означает символ @ , #, $ , ^

3. Не используя функцию возведения в квадрат, напишите на языке Паскаль наиболее короткие алгоритмы вычисления а) y=x¹° б)y=x¹⁵ или а) y=x^10

б)y=x^15

Постараться использовать минимальное количество дополнительных переменных.

4. Запишите на языке Паскаль программу циклического обмена значениями трёх переменных a,b,c. Схема циклического обмена: a ← b ← c. Например, если до обмена было: a=1, b=2, c=3, то после обмена должно стать: a=2, b=3, c=1.

ПАСКАЛЬ!

как на языке паскаль записать
корень5x - корень4y +1
??

Прошу переделать код программы с языка Паскаль на С++.

Вот код Паскаль:
var
f:array[1..500] of record
fam:string;
bal:boolean;
end;
buf:boolean;
str:string;



Вы находитесь на странице вопроса "В ПАСКАЛЕ", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.