Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Постройте алгоритм угадывания числа от 1 до 10

5-9 класс

Andreiyas 08 марта 2015 г., 18:58:08 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Axegold
08 марта 2015 г., 19:46:27 (9 лет назад)

var ch,ch1:integer;

begin
ch:=random(10)+1;
writeln('Ugadai vvedi chislo ot 1 do 10');
readln(ch1);
if ((ch1 <10) and (ch1 > 0) ) then
if (ch1=ch)then writeln('Ty ugadal')
else writeln('Ty ne ugadal, chislo = ',ch)
else writeln('Error');

end.

Ответить

Другие вопросы из категории

Условие на украинском и на русском во вложениях, решите плиз!!!

задание лёгкое!С права на русском!

Читайте также

Задание 4.Составте программу ,выводящую на экран числа от 1 до 10 , по одному числу в строке.

Задание 5.Дополните программу из задания 4 так , чтобы на экран выводились числа от 1 до 10,а также квадраты и кубы этих чисел в следующем виде:
1 1 1
2 4 8
3 9 27
... ... ...
10 100 1000

ПОМОГИТЕ ПОЖАЛУЙСТА,ЗАДАНИЕ 4 ПИСАТЬ НЕ НУЖНО !ПОСТАВЛЮ ЛУЧЩИЙ ОТВЕТ И "СПАСИБО"

ССССРРРРРРРРРРРРРРЛОООООООООООЧЧЧЧЧЧЧЧНООООООООО!!! 1. Заполнить одномерный массив, состоящий из 10 элементов, случайными числами от-15 до 35.

Найти сумму элементов данного массива.
2. Заполнить одномерный массив, состоящий из 10 элементов, случайными числами от-15 до 35.
Найти значение максимального элемента массива.

4 а) составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 , затем элементы с четными индексами

удваиваются , а элементы с нечетными индексами утраивает.Выведите на экран исходный и полученный массив.

б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 , затем изменяет знак элементов с четными индексами на противоположный .Выведите на экран исходный и полученный массивы.

5) а)составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит количество элементов ,которые больше своего соседа слева

б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 и находит количество пар элементов с четными значениями.

6) а)составьте программу ,которая заполняет массив а[1..20 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит среднее арифметическое элементов с четными значениями и нечетными индексами.

б) составьте программу ,которая заполняет массив b[1..15 ] случайными целыми числами в диапозоне от 1 до 20 и выводит все тройки элементов , упорядоченные строго по возрастанию.

1)Составте программуб которая заполняет массив а[1..10] случайными целыми числами в диапозоне от 1 до 10,затем преобразовывает его,увеличивая все

элементы с четными значениями на 1. Если элементы с чётными значениями отсутствуют, оставить массив без изменений.

2) Составте программуб которая заполняет массив а[1..10] случайными целыми числами в диапозоне от 1 до 10,затем преобразовывает его,увеличивая все элементы с нечётными значениями в три раза,а элементы с чётными значениями заменяя на 0.



Вы находитесь на странице вопроса "Постройте алгоритм угадывания числа от 1 до 10", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.