Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Составьте программу, которая получает на вход с клавиатуры три различных целых числа a,b,c (каждое число – с новой

5-9 класс

строки) и выводит на экран сумму максимального и следующего за ним по величине числа. Каждое число по абсолютной величине не превышает 10 000.

бледнолицая 03 апр. 2015 г., 16:58:02 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Snake77tan
03 апр. 2015 г., 17:41:58 (9 лет назад)

var a, b, c, max, mid : integer;
Begin
    read(a);
    read(b);
    read(c);
   
    if (a >= b) then begin
        max := a;
        mid := b;
    end
    else begin
        max := b;
        mid := a;
    end;

    if (mid < c) then
        mid := c;
   
    writeln(max + mid);
End.

Ответить

Другие вопросы из категории

помогите решить задачи
Кто-нибудь может объяснить как решить эту задачку, вообще не понимаю....

Символом F обозначено одно из указанных ниже логических выражений от трех аргументов: X, Y и Z. Дан фрагмент таблицы истинности выражения F. Какое выражение соответствует F?
Варианты:
1) ¬X ^ ¬Y ^ Z
2) ¬X v ¬Y v Z
3) X v Y v ¬Z
4) X v Y v Z

Составьте программу для решения задачи : при каком значении N произведение станет меньше 0.1

p=1/2*1/4...1/2N;
Турбо паскаль!!!!
знаю задача не очень то и сложно но я забыл как решать такого типа помогите люди пожалуйста срочно нужно

Читайте также

Составить программу, которая выводит на экран в обратном порядке нечетные числа от 29 до 1 в Pascal ABC.

Составить программу,которая выводит на экран сумму нечетных чисел от 1 до 30 в Pascal ABC.


составьте программу, которая вставляет слово ОБА после каждого слова, заканчивающегося на гласную.

Или

составьте программу, которая определяет на сколько в строке S слов, начинающихся на главную букву больше, чем в строке T

надо решить одну из них

1)Составить программу которая выводит на экран каждое 5-ое число и таких чисел 20.

2)Составить программу которая вычисляет произведение натуральных чисел от 5 до 10.

1)составьте программу ,которая предлагает ввести с клавиатуры две строки ,а затем выводит это строки на экран в алфавитном порядке

например армия(строка а)
арбуз (строка б)
2)составьте программу ,которая предлагает ввести с клавиатуры две строки а и б ,соеденяет их и выводит результат в одну строку
например: тепло(строка а)
ход(строка б)

Помогите составить программу по информатике в Pascal ABC. Задание 1. С клавиатуры одной строковой вводят имя и фамилию. Составьте программу, которая:

а) определяет, есть ли в определенной строке заданный символ; б) копирует в новую строку имя и выводит его; в) выводит сначала фамилию, а затем имя. Задание 2. Составьте программу, которая в строке "Касіу Ясь канюшыну" заменяет имя "Ясь" на "Янка". Задание 3. Составьте программу, которая в строке "реки горы и болота": а) удаляет слово "горы"; б) Заменяет слово "болота" на "озера". Буду безмерно благодарна!!!



Вы находитесь на странице вопроса "Составьте программу, которая получает на вход с клавиатуры три различных целых числа a,b,c (каждое число – с новой", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.