Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Помогите составить программу по информатике в Pascal ABC. Задание 1. С клавиатуры одной строковой вводят имя и фамилию. Составьте программу, которая:

5-9 класс

а) определяет, есть ли в определенной строке заданный символ; б) копирует в новую строку имя и выводит его; в) выводит сначала фамилию, а затем имя. Задание 2. Составьте программу, которая в строке "Касіу Ясь канюшыну" заменяет имя "Ясь" на "Янка". Задание 3. Составьте программу, которая в строке "реки горы и болота": а) удаляет слово "горы"; б) Заменяет слово "болота" на "озера". Буду безмерно благодарна!!!

ICoksharov 11 окт. 2014 г., 23:28:47 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Юнонка
12 окт. 2014 г., 2:03:18 (9 лет назад)

Задание 1

a)

program pr;

var

s:string;

c:char;

i:integer;

begin

writeln('Введите имя и фамилию в одной строке');

readln (s);

writeln('Введите заданный символ');

readln (c);

for i:=1 to length(s) do if s[i]=c then writeln ('В строке найден заданный символ');

readln;

end.

б)

program pr;

var

s,n:string;

c:char;

i:integer;

begin

writeln('Введите имя и фамилию в одной строке');

readln (s);

i:=1;

while s[i]<>' ' do i:=i+1;

n:=copy(s,1,i-1);

writeln(n);

readln;

end.

в)

program pr;

var

s,n,f:string;

c:char;

i:integer;

begin

writeln('Введите имя и фамилию в одной строке');

readln (s);

i:=1;

while s[i]<>' ' do i:=i+1;

n:=copy(s,1,i-1);

f:=copy(s,i+1,length(s)-i+1);

writeln(n);

writeln(f);

readln;

end.

Задание2

program pr;

var s:string;

begin

s:='Касіу Ясь канюшыну';

delete (s,7,3);

insert ('Ясь',s,7);

writeln (s);

readln;

end.

Задание 3

а)

program pr;

var

s:string;

begin

s:='реки горы и болота';

delete (s,6,5);{удаляем включая пробел}

writeln (s);

readln;

end.

б)

program pr;

var

s:string;

begin

s:='реки горы и болота';

delete(s,13,6);

s:=s+'озера';

writeln (s);

readln;

end.

 

 

 

 

 

 

 

 

Ответить

Читайте также

Помогите составить программу по информатике в Pascal ABC. Задание 1. С клавиатуры одной строковой вводят имя и фамилию. Составьте программу, которая: а)

определяет, есть ли в определенной строке заданный символ; б) копирует в новую строку имя и выводит его; в) выводит сначала фамилию, а затем имя. Задание 2. Составьте программу, которая в строке "Касіу Ясь канюшыну" заменяет имя "Ясь" на...

1)С клавиатуры одной строкой вводят имя и фамилию.Составьте программу,которая выводит сначала фамилию,а потом имя.(Стонько Роман) 2)Составьте

программу,которая в строке"рэки,горы и балоты" удаляет слова"горы"

ПОМОГИТЕ ОЧЕНь ОЧЕНь ОЧЕНЬ СРОЧНО НОДО, ВОПРОС ЖИЗНИ И СМЕРТИ!!!!!!!!!!

Очень срочно, и очень нужно составить программы по информатике PASCAL ABC, помогите, пожалуйста от этих программ зависит моя четвертная.

1. Составьте программу для определения большего из двух чисел х или у
2. Составьте программу для нахождения площади прямоугольника по заданным сторонам а и б

Помогите,пожалуйста,написать программу по информатике.Вот такое условие:

Составьте программу, которая формирует массив из 40 случайных целых чисел от 0 до 20 и вычисляет:
1). сумму чисел, не превышающих 10;
2). сумму чисел,кратных 3. Помогите пожалуйста,написать эту программу на PaskalABC.

Помогите составить программу по Паскалю, пожалуйста.

Клоун
предложил каждому из публики задумать число. Потом он сказал: «Прибавьте к
задуманному числу 5. Теперь из результата вычтите 2. А теперь к результату
прибавьте 7». Потом клоун спросил у желающих, какое число у каждого из них
получилось. Услышав ответ, он немедленно объявлял каждому, какое число тот
задумывал. Составьте программу, которая повторяла бы фокус клоуна.



Вы находитесь на странице вопроса "Помогите составить программу по информатике в Pascal ABC. Задание 1. С клавиатуры одной строковой вводят имя и фамилию. Составьте программу, которая:", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.