Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Перевести из десятичной системы счисления к двоичной системе счисления: 237,1015,3000,55 p.s п желанию можно подробное решение

5-9 класс

Yakjhh2014 08 нояб. 2016 г., 10:25:13 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Guest2004
08 нояб. 2016 г., 11:19:27 (7 лет назад)

237 = 11101101

Сначала делим на 2:

237 / 2 = 118(1)(так-как есть остаток)

118 / = 59(0)(так-как нет остатка)

59 / 2 = 29(1)

29 / 2 = 14(1)

14 / 2 = 7(0)

7 / 2 = 3(1)

3 / 2 = 1(1)

1 / 2 = 0(1)

А потом записываем с конца.

 

С остальными так-же.(но лучше воспользоваться стандарнным windows'ким калькулятором(вид->программист->и когда введёшь число выбрать Bin :))

+ 0 -
Жанчиик
08 нояб. 2016 г., 12:24:53 (7 лет назад)

237/2=118 (остаток 1)

118/2=59 (остаток 0)

59/2=29(остаток 1)

29/2=14(остаток1)

14/2=7(остаток 0)

7/2=3(остаток 1)

3/2=1(остаток1)

Теперь записываем остаток снизу вверх т.е 1101101 (это и будет число 237)

Все остальные числа также:

1015=1111110111

3000=101110111000

55=110111

Ответить

Другие вопросы из категории

Var x,y,z,d:integer;

b1,b2,b3,b4,b5,b6:boolean;
begin
Write('введите 4 любых числа');
readln(x,y,z,d);
b1:=x+y>z-d;
b2:=x-y<=z+d;
b3:=x/y<z*d;
b4:=x*y>=z/d;
b5:=x+y=z+d;
b6:=x-y<>z-d;
Write('сумма первого и второго больше разности второго и третьего;b1');
WRITE('разность первого и второго больше или равна сумме третьего и четвертого;b2');
write('деление первого и второго меньше произведения третьего и четвертого;b3');
write('произвдение первого и второго больше или равна делению третьего и четвертого;b4');
write('сумма первого и второго равна сумме третьего и чертогоb5');
write('разность первого и второго не равна разности третьего и четвертого');
Readln (b1,b2,b3,b4,b5,b6);
End.
исправьте, в паскале, просит ввести доп данные, а я не знаю что делать:(

составьте программу заполнения массива а[1..10] нечетными числами:

индексы элемента 1 2 3 4 5 6 7 8 9 10
значение элемента 1 3 5 7 9 11 13 15 17 19

Читайте также

перевести числа из двоичной системы счисленния в заданную

а) 34(10)степень-в степень с 2 ?
б)234(10)- 8?
в)1268(10)-16?
пеевести из из двоичной системы счисленния в заданную
а)10110101011(2)-8?
б)10010110101001(2)-8?
в)10001011010011(2)-16?
г)100101101010010(2)-16?
перевести числа из заданной системы счисление в двоичную
а)25463(8)
б)24501( 8)
в)125FE20(16)
г)2155BO(16)

1)Переведите число из двоичной системы счисления в десятичную, восьмеричную,шестнадцатеричную:1000111001.

2)Переведите число из десятичной системы счисления в двоичную,восьмеричную,шестнадцатеричную:1517.
3)Переведите число из восьмеричной системы счисления в десятичную, двоичную:11123.

1)Переведите число из двоичной системы счисления в десятичную, восьмеричную,шестнадцатеричную:1000111001.

2)Переведите число из десятичной системы счисления в двоичную,восьмеричную,шестнадцатеричную:1517.
3)Переведите число из восьмеричной системы счисления в десятичную, двоичную:11123.

Перевести число 173 из десятичной системы счисления в двоичную. Перевести число 110111011из двоичной системы счисления в десятичную. Записать

представление числа -115 в однобайтовой ячейке. Выполнить сложение в двоичной системе счисления: 110101+10101, 11010+11001 Выполнить умножение в двоичной системе счисления: 110101+10101, 11010+11001

1. Назовите преимущества и недостатки двоичной системы счисления по сравнению с десятичной.

2. Какие двоичные числа соответствуют следующим десятичным числам: 128;256;512;1024?
3. Чему в десятичной системе равны следующие двоичные числа: 1000001; 10000001; 100000001; 1000000001?
4. Переведите в десятичную систему следующие двоичные числа: 101; 11101; 101010; 100011; 10110111011.
5.Переведите в двоичную систему счисления следующие двоичные числа: 2; 7; 17; 68; 315; 765; 2047.
6.Выполните сложение в двоичной системе счисления:11+1; 111+1; 1111+1; 11111+1.
7.Выполните умножение в двоичной системе счисления: 111*10; 111*11; 1101*101; 1101*1000.



Вы находитесь на странице вопроса "Перевести из десятичной системы счисления к двоичной системе счисления: 237,1015,3000,55 p.s п желанию можно подробное решение", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.