Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Ввести три числа.Увеличивать третье из них в 3 раза пока оно не будет больше средне арифмитического.На экран выдавать числа и их

10-11 класс

среднеарифметическое.

Nikita3570 09 авг. 2014 г., 22:06:09 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Sasha1234567891011
10 авг. 2014 г., 0:39:03 (9 лет назад)

uses crt;
var a,b,c,s:real;
begin
write('Введите 3 числа: ');
readln(a,b,c);
repeat
begin
c:=c*3;
s:=(a+b+c)/3;
write('Числа: ',a:5,b:5,c:5,' Их среднее арифметическое: ',s:5);
writeln;
end;
until c>s;
end.

Ответить

Другие вопросы из категории

Какой метод заложен в основу архитектуры RISC микропроцессоров?

1) сокращение набора команд процессора за счет моделирования сложных команд обращения к памяти посредством более простых и быстрых команд работы с регистрами

2) введение нескольких параллельно работающих АЛУ конвейерного типа и разбиение кажцой сложной команды на подоперации, которые могут исполняться в параллельно конвейерном режиме

3) механизм параллельной обработки структурированных данных (массивов, матриц) за счет использования циклических команд повтора (repeated instruction set computer)

4) механизм разгона ядра процессора, позволяющий работать на более высоких частотах, что повышает быстродействие, но снижает надежность

5) ускорение выполнения команд за счет перехода на медные проводники

Integer8◦

. Дано двузначное число. Вывести число, полученное при переста-
новке цифр исходного числа.

1011011,01+1000101110,1001
Выберите правильный вариант ответа.Назовите устройство входящее в состав процессора а)оперативная запоминаюустройство,принтер

б)арифмитико-логическое устройство управления

в)кэш-память,

г)сканер,

д)дисплей,процессор

Читайте также

1. Ввести три числа, найти их сумму, произведение и среднее арифмитическое:

Пример: Ввести 3 числа.
4 5 7
4+5+7=16
4*5*7=140
(4+5+7):3=5,3(3)

У исполнителя Аккорд две команды, которым присвоены номера:1. отними 12. умножь на x(x – неизвестное положительное число)Выполняя первую из них, Аккорд

отнимает от числа на экране 1, авыполняя вторую, умножает это число на x.Программа для исполнителя Аккорд – это последовательность номеровкоманд.Известно, что программа 12121 переводит число 6 в число 119.Определите значение x.

3. Даны два неравных числа X и Y. Большее из них заменить на сумму этих чисел, а меньшее увеличить в три раза.

4. Известны периметр первого треугольника Р1, координаты вершин второго x1, y1, x2, y2,x3, y3 и длины сторон третьего – а3, в3, с3. Найти и вывести на экран периметр меньшего треугольника.

Алгоритмы ветвления

Петя, Вася и Маша остались дома одни. Кто-то из них ел варенье. На вопрос мамы, кто это сделал, они сказали:

а) Петя: "Я не ел. Маша тоже не ела."
б) Вася: "Маша действительно не ела. Это сделал Петя"
в) Маша: "Вася врет. Это он съел."

Выясните, кто ел варенье, если известно, что двое из них оба раза сказали правду, а третий один раз соврал, а один раз сказал правду.(Если можно, то с помощью лог. формулы или таблицы, пожалуйста)



Вы находитесь на странице вопроса "Ввести три числа.Увеличивать третье из них в 3 раза пока оно не будет больше средне арифмитического.На экран выдавать числа и их", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.